2

I have a laptop (Lenovo Thinkpad T540p) with dualboot Windows and Ubuntu Ubuntu 12.04.4 LTS. I need to make frequent use of the F keys (F1 through F12), but I must always press in the combination fn + F1-F12 and it's getting annoying.

This happens only on Ubuntu so I'm guessing there should be a setting in Ubuntu which I can modify. I have tried the two solutions from these answers but I don't have a .xinitrc file and xkeycaps doesn't do the trick.

I have also tried the Solaar answer but it doesn't show any device..

In short: F1 mutes my sound while Fn + F1 brings up the help and I want it the other way around

--Edit April 14

I have included a screenshot of my bios with the available options for keyboard/mouse

BIOS Screenshot

As you can see: I only have three available options.

5
  • You could boot a live cd of the 14.04 beta just to see if the hardware support is better. Apr 2 '14 at 12:54
  • This is a work pc so I would rather not migrate to a beta
    – Noosrep
    Apr 2 '14 at 12:58
  • I was not suggesting to migrate but to try a live cd, btw could you add to your question the point release you're using? 12.04.4? Apr 2 '14 at 13:00
  • Added the point release, it's indeed 12.04.4
    – Noosrep
    Apr 2 '14 at 13:06
  • 14.04 will be out soon (two weeks from tomorrow) it might be worth a try (on a liveCD that is).
    – Seth
    Apr 2 '14 at 23:16
1

In my Lenovo G500 and there's a setting in the BIOS for this - see the screenshot below. If you don't have this you may need to update your BIOS from here. It's dated March 2014 so it's pretty recent (this is for Win 8.1). You can see from the description in the screenshot that it does exactly what you want.

BIOS page showing hotkey mode enable/disable

5
  • But wouldn't this change the behaviour on Windows since it works there correctly?
    – Noosrep
    Apr 9 '14 at 13:38
  • That didn't work because I don't have those options. I've included a screenshot of my bios setup
    – Noosrep
    Apr 14 '14 at 9:30
  • What BIOS Version are you running? Unfortunately there's little info about what the differences are but it might be worth upgrading.
    – Scooby-2
    Apr 15 '14 at 15:55
  • GMET31WW (1.11 ) is my BIOS version
    – Noosrep
    Apr 16 '14 at 6:15
  • From the link in my answer above you can download the latest version, V2.10 (GMET62WW). I don't know if this will add the functionality you need but IMO it is not a bad idea to use the latest version. You are four versions behind the latest, which was only released less than a month ago (27th March). Be sure to view the associated readme file.
    – Scooby-2
    Apr 17 '14 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.