I am using Ubuntu 13.10 with Unity desktop. Unfortunately I am not able to log into my desktop. After entering correct password it keeps looping back to login.

Could you please help me to sort out this problem? I need help because I have important data in my laptop and I don't want to reinstall the OS.

This is my /etc/lightdm/lightdm.conf file:


This is the output of output after lspci|grep VGA :-

00:02:0 VGA compatible controller: Intel corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c) 
  • What did you do last time you logged in? – Danatela Apr 2 '14 at 9:18
  • Nothing It works fine when I was last logged in. After that I was unable to login my personal computer. – Rohan Dongre Apr 2 '14 at 9:20
  • Can you select Recovery mode at boot? – Danatela Apr 2 '14 at 9:25
  • Yes I can select recovery mode. – Rohan Dongre Apr 2 '14 at 9:41
  • @RohanDongre I suggest that it will help those who are trying to answer if you paste your lightdm.conf file which is in /etc/lightdm in pastebin.ubuntu.com and provide the link to it in the description of your question. If lightdm.conf is not present in your PC then you must probably paste your /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf file or something else like that. – VenkiPhy6 Apr 10 '14 at 14:43

Select Recovery mode during boot then Drop to root shell prompt.

From there, run (I assume rohan is your login name)

mount -o rw,remount /  #remount / filesystem in read-write mode
passwd rohan

Then enter your password and press Ctrl+D. Now you should be able to login.

|improve this answer|||||
  • Could you please tell me how to Remount filesystem in read-write mode ? could you please tell me step by step because I am not expert user of linux ? – Rohan Dongre Apr 2 '14 at 9:59
  • See the updated answer. – Danatela Apr 2 '14 at 10:08
  • Thanks Danatela, I will try this solution and let you know if there is any issue. – Rohan Dongre Apr 2 '14 at 10:28
  • Sorry to say but solution doesn't worked for me. I have tried by changing ownership of .Xauthourity file too and I have installed gdm also but after reconfiguring gdm it shows that gdm is too heavy for my system may be because of my system configuration. My system has 2 gb RAM and intel core2duo processor. – Rohan Dongre Apr 3 '14 at 8:15
  • Try to add new user and login to that user. – Danatela Apr 3 '14 at 8:22

Here I am sharing how I make my desktop on. After getting help by peoples who gave to solve my problem which was I facing from few days back, unfortunately they didn't worked for me.

So I thought lets try it by upgrading distro version from 13.10 to 14.04 LTS. and it works for me and now I am able to logged in my desktop.

Thanks to @Venki, @Danatela for helping me to sort out my problem.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.