0

So I cannot connect using my Ubuntu OS but I can with windows The internet can work with Google but as soon as I try any other site it crashes

I ran ifconfig and got the following

eth0      Link encap:Ethernet  HWaddr 90:2b:34:13:12:a3  
          inet addr:130.215.246.212  Bcast:130.215.246.255  Mask:255.255.255.128
          UP BROADCAST RUNNING MULTICAST  MTU:922  Metric:1
          RX packets:30 errors:0 dropped:30 overruns:0 frame:30
          TX packets:54 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5126 (5.1 KB)  TX bytes:9875 (9.8 KB)
          Interrupt:41 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
~$ host google.com

google.com has address 74.125.225.0
google.com has address 74.125.225.6
google.com has address 74.125.225.5
google.com has address 74.125.225.7
google.com has address 74.125.225.3
google.com has address 74.125.225.2
google.com has address 74.125.225.14
google.com has address 74.125.225.4
google.com has address 74.125.225.1
google.com has address 74.125.225.8
google.com has address 74.125.225.9
google.com has IPv6 address 2607:f8b0:4009:806::100e
google.com mail is handled by 30 alt2.aspmx.l.google.com.
google.com mail is handled by 20 alt1.aspmx.l.google.com.
google.com mail is handled by 50 alt4.aspmx.l.google.com.
google.com mail is handled by 10 aspmx.l.google.com.
google.com mail is handled by 40 alt3.aspmx.l.google.com.
~$ nm-tool

NetworkManager Tool
State: connected (global)
- Device: eth0  [WPI-Wired] ----------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             connected
  Default:           yes
  HW Address:        90:2B:34:13:12:A3

  Capabilities:
    Carrier Detect:  yes
    Speed:           1000 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         130.215.246.212
    Prefix:          25 (255.255.255.128)
    Gateway:         130.215.246.129

    DNS:             130.215.32.18
    DNS:             130.215.39.18
    DNS:             130.215.5.18

Then I try to run something and get

~$ host google.com
;; connection timed out; no servers could be reached

Any help would be very much appreciated

  • 1
    What crashes? Can you describe what actually happens? Ubuntu certainly doesn't crash because you open a connection to another server than google.com :) – Jo-Erlend Schinstad Apr 2 '14 at 3:07
  • I think he means that Google works (from the cache I guess ;)) but no other site, due to no connection. – Jacob Vlijm Apr 2 '14 at 6:08
  • can you give as output from nm-tool command? Probably you have problem with dns setting. Also you can try in console host google.com. If is your dns setting ok you will got ip address... – 2707974 Apr 2 '14 at 7:40
  • ~$ host google.com google.com has address 74.125.225.0 google.com has address 74.125.225.6 ect – user264436 Apr 3 '14 at 18:24
  • Ive preformed those commands, let me know if that helps – user264436 Apr 3 '14 at 18:30
0

Try different DNS settings: 8.8.8.8 and 8.8.4.4 (short guide here, may be a little outdated but should work: http://ubuntuforums.org/showthread.php?t=2078398)

Also make sure your subnet is correct. I manage over a ton of networks at my day job and a mistyped subnet can cause all sorts of problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.