0

I have added the locale language at installation. But now, When I change the language from toolbar, It still types English. System is installed freshly and has latest updates.

Edit:

I have removed the Persian and Added Persian (with Persian keyboard). Now I can switch the language throw toolbar, But when I change it via Alt + Shift , The language name on toolbar changes but the input language still is English.

  • I have Ubuntu-Gnome 13.10
  • Language: Persian (fa)

What is the solution?

  • The Persian was there, But I removed it and added "Persian (With Persian keyboard" But still have another problem (I'll add it to the question) – Mohammad Etemaddar Apr 1 '14 at 14:46
  • @user68186: I think its not duplicate now. My problem is changed now. – Mohammad Etemaddar Apr 1 '14 at 14:53
1

Updated for Ubuntu 18.04

Click on the icons on top right corner and select Screwdriver & Wrench icon at the bottom of the drop-down menu. Then select the Devices from the left panel. Then select the Keyboard from the left panel. This will bring you to the table of keyboard shortcuts.

Scroll down to the Typing section and find two entries:

  • Switch to next input source Super+Space
  • Switch to previous input source Shift+Super+Space

Select Switch to next input source and follow the instructions on the screen and press the keyboard shortcut you want to use such as Ctrl+Space.

Select Switch to previous input source and follow the instructions on the screen and press the keyboard shortcut you want to use such as Shift+Ctrl+Space.

Original Answer

Click on the power/Gear icon on top right corner and select System Settings... Then select the Text Entry icon under Personal. Make sure Persian is listed. If not, add it by clicking on the + sign.

I find it hard to use any combination with Alt as it brings up the HUD. To change this return to Text Entry as before and click on the space under Switch to next source using: where it says Alt+Shift and enter another combination such as Cntrl+Space.

Next click on the space under Switch to previous source using and enter another combination such as Shift+Cntrl+Space.

Hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.