Due to Windows 7 boot error I've decided to make a liveUSB as a possible fix method. I used a 4 GB USB stick and dedicated 1 GB as persistent. On first boot everything was fine but from the second boot onwards I haven't been able to access any of the 'drives'. That includes both hard drives (one is malfunctioning anyway but that's another story), the two Windows partitions and even Casper. I can access an SD stick only if it was present during boot. If I remove and reinsert it, I get an error message.

When trying to access the main Windows partition I get this error message:

Error mounting /dev/sdb2 at /media/ubuntu/Windows7_OS: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=999,gid=999,dmask=0077,fmask=0177" "/dev/sdb2" "/media/ubuntu/Windows7_OS"' exited with non-zero exit status 21: mount: according to mtab, /dev/sdb2 is already mounted on /media/ubuntu/Windows7_OS

This is like with the two other HDD partitions/drives, only with different locations. For Casper I get:

Device /dev/loop1 is already mounted at `/media/ubuntu/casper-rw3'.

When loading the live USB I've tried "check disc for errors" and it found two errors. It didn't tell me what those were and it didn't seem to fix/change anything, since it gave me the same message the second time I ran "check disc for errors".

How can I regain access?

Update: It's been over a week now and still no improvement, things are just getting worse. Since the system seems to have problem accessing the persistent partition on the USB flash drive, various changes cannot be saved properly, like Firefox crash screen (and other various crashes when HDMI cable is plugged/unplugged).

Is there anything i can do besides a reinstall of the LiveUSB?


I had the same problem. Searched a lot, but didnt find anything. Had to create the casper.rw file again.

Copy the data you need on your USB flash drive and then use this casper recreator on windows..:


(casper.rw contains all your persistent session data. recreating it will wipe it all.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.