Question what could be the source of this error:

Error The AWS Access Key Id you provided does not exist in our records.


  • Windows 8.1 running the 1.16.6 windows juju client access via command-line-window.

What has been done so far:

  • Have a AWS account setup
  • Have keys named correctly and installed in the .ssh directory
  • Have modified the .yaml file to have the Access key and secret key

Edit 1: - can create instances via EC2 console - can login to instances via SSH Putty and key pairs - have setup user with IAM including EC2 and S3 full access rights as per this link Tried to follow the EC2 Juju guide and it fails

Get the above error when issue the following command "juju bootstrap" If I use the command juju bootstrap -v it adds the following to the error: ERROR juju supercommand.go:282 .....

I have searched google and this forum but didn't find any other post that addressed this issue that I haven't already tried. What might I be missing?

  • Can you ensure that you can launch AWS instances from their console? – Jorge Castro Mar 31 '14 at 22:06
  • Sorry I didn't mention that. Yes I can they appear to run fine. I can ssh into the instance using the key pair and ssh (Putty). – Joshua Smith Apr 1 '14 at 0:21
  • Also notice I get the same error if I try juju status – Joshua Smith Apr 1 '14 at 0:48

Ok I found the answer.

  1. When running on windows client the first time you run juju bootstrap it creates an environments folder, which contains the .jenv file. What this means if you later change the .yaml file the changes may not be copied over into the .jenv file. So if having trouble you must delete the .jenv/environments folder after each change to the .yaml file.

  2. The issue is I left the <> on the secret-key and access-key, the keys should not have the <>. I had tried several times with the brackets and without the brackets, but didn't realize I had to first delete the .jenv file for it to create a new one with the changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.