0
sudo mount -o user=www-data,group=www-data --bind /home/chachan/workspace/ /var/www
sudo mount -o owner=www-data,group=www-data --bind /home/chachan/workspace/ /var/www
chachan@magento:~$ sshfs chachan@192.168.56.1:/home/chachan/workspace/magento /home/chachan/workspace
chachan@magento:~$ sudo mount -o owner=www-data,group=www-data --bind /home/chachan/workspace/ /var/www
chachan@magento:~$ ls -lh /var/www
total 700K
-rw-r--r-- 1 chachan chachan 2.8K Nov 26 10:44 api.php
drwxr-xr-x 1 chachan chachan 4.0K Nov 26 10:44 app
-rw-r--r-- 1 chachan chachan 2.8K Nov 26 10:44 cron.php
-rw-r--r-- 1 chachan chachan  717 Nov 26 10:44 cron.sh
drwxr-xr-x 1 chachan chachan 4.0K Nov 26 10:44 downloader
drwxr-xr-x 1 chachan chachan 4.0K Nov 26 10:44 errors
-rw-r--r-- 1 chachan chachan 1.2K Nov 26 10:44 favicon.ico
-rw-r--r-- 1 chachan chachan 5.9K Nov 26 10:44 get.php
drwxr-xr-x 1 chachan chachan 4.0K Nov 26 10:44 includes
-rw-r--r-- 1 chachan chachan 2.6K Nov 26 10:44 index.php
-rw-r--r-- 1 chachan chachan 2.4K Nov 26 10:44 index.php.sample
-rw-r--r-- 1 chachan chachan 6.3K Nov 26 10:44 install.php
drwxr-xr-x 1 chachan chachan 4.0K Nov 26 10:44 js
drwxr-xr-x 1 chachan chachan 4.0K Nov 26 10:44 lib
-rw-r--r-- 1 chachan chachan  11K Nov 26 10:44 LICENSE_AFL.txt
-rw-r--r-- 1 chachan chachan  11K Nov 26 10:44 LICENSE.html
-rw-r--r-- 1 chachan chachan  11K Nov 26 10:44 LICENSE.txt
-rw-r--r-- 1 chachan chachan 1.3K Nov 26 10:44 mage
drwxr-xrwx 1 chachan chachan 4.0K Mar 31 09:33 media
-rw-r--r-- 1 chachan chachan  886 Nov 26 10:44 php.ini.sample
drwxr-xr-x 1 chachan chachan 4.0K Nov 26 10:44 pkginfo
-rw-r--r-- 1 chachan chachan 572K Nov 26 10:44 RELEASE_NOTES.txt
drwxr-xr-x 1 chachan chachan 4.0K Nov 26 10:44 shell
drwxr-xr-x 1 chachan chachan 4.0K Nov 26 10:44 skin
drwxr-xrwx 1 chachan chachan 4.0K Nov 26 10:44 var

I want to have www-data:www-data as owner:group in the above list of files.

Any idea what am I missing or doing wrong?.

Thanks

1

I fixed adding uid, gid and allow_another options for sshfs. Like this:

sshfs -o uid=33,gid=33,allow_another chachan@192.168.56.1:/home/chachan/workspace/magento /home/chachan/workspace

I also added (uncomment) user_allow_other option to /etc/fuse.conf and it's working smoothly :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.