1

I am currently having a very strange problem with the KDE widget style.

The problem consists in that the widget styles are not respected. All windows appear with something that looks like the default GTK style (I don't know the name). If I change the style in systemsettings, the appearance for currently open windows change, but new windows continue to appear with the wrong style.

This does not seem to be affected by which style I choose in the settings (I have tested with Oxygen, Plastique and Skulpture. Also, I have confirmed that opening applications with the style set by the command line (such as ksysguard --style oxygen) does work.

I have not found any information whatsoever in the Internet about this (probably because all the results are about KDE-GTK engines, which this is not about.

I don't know if this has to do with any of it, but this is happening ever since upgrading from 13.04 to 13.10.

EDIT: To clarify, here goes screenshots:

If I simply open any KDE program, I get this (rename file dialog from a Dolphin instance), which is not the Oxygen style I set it to:

enter image description here

If I go to System Settings->Application Appearance->Style, set any option (i.e. changing an option and immediately reverting it, just so the Apply button will be enabled, I get the following appearance (correct style). This also happens when I launch a program with the style set by command line (--style oxygen).

enter image description here

  • If you are trying to do "customised", i.e. with different themes for different elements, it's a bit broken at the moment. – Sparhawk Apr 2 '14 at 5:12
  • No, this is about setting any widget style. Whatever the settings are, the style is different when I open a new window. – Rafael Lerm Apr 2 '14 at 17:06
  • I not 100% sure which setting you mean. Can you be more explicit, and perhaps link to a screenshot? – Sparhawk Apr 3 '14 at 2:55
  • The setting i am refering to is the widget style, the one you control in System Settings->Application Appearance->Style. – Rafael Lerm Apr 3 '14 at 15:35
  • Thanks for that. I understand now, but I'm afraid I can't help. Hopefully someone else will chime in. If you don't hear anything, you can always ask at forum.kde.org – Sparhawk Apr 3 '14 at 22:27
1

I decided to try searching for this again, and found an answer in this Arch Linux forum

First I had to install the qtconfig utility:

sudo apt-get install qt4-qtconfig

Then, running qtconfig, I changed the first option ("Select GUI Style") from "Cleanlooks" to "Desktop Settings", and that did it.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.