I removed the password from my account using the "User Accounts" window and then on running sudo, it prompted me for a password, even when i didn't have one. I tried pressing enter without entering anything but it didn't help.

Also I couldn't unlock my account to set a new password in the "User Accounts" window in "System Settings" because it kept prompting for a password and wouldn't except an empty string, just like sudo. I then finally set a new password using passwd.

Is this a bug which shouldn't be happening? How do I prevent this from happening?

  • Did you try to logout and then login again? – Nikos Grigoriadis Mar 31 '14 at 16:04
  • @NikosGr resetting the password using passwd solved the problem. – udiboy1209 Mar 31 '14 at 16:55

If you must remove the need for a password to use sudo, you can edit the /etc/sudoers file using sudo visudo command.

# User privilege specification
root    ALL=(ALL:ALL) ALL

# Members of the admin group may gain root privileges
%admin ALL=(ALL) ALL

# Allow members of group sudo to execute any command

and add NOPASSWD:ALL for sudoers group as shown above


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.