1

Whenq I turnqed my computer onq today, the keyboard started typinqg extra characters like inq this messed up senqtenqce. The only way to get rid of the extra characters is to highlight them and press delete on the keyboard because pressing backspace just types a backslash which it then deletes. The keys affected are below:

  • Pressing 'n' types 'nq', as does pressing 'q'
  • Pressing backspace types a backslash, which is then "backspaced"
  • Pressing 'b' moves the cursor back to the beginning of the text field.
  • Pressing 'z' types '\z', as does pressing '\'
  • Pressing '.' on the numpad types '<.'

I am using Xubuntu 13.10, the default drivers, the "Logitech Generic Keyboard" layout, and Solaar to pair the keyboard with my Unifying Receiver. The extra characters are also typed in the grub console. It also took me about 20 minutes to type this. UPDATE: tried swapping the unifying receivers that came with the mouse I have and the keyboard, did nothing to help.

0

If you have lent your computer to a friend, or if someone else got in the neighborhood of your computer, then I would look at the calendar and ask him/her for help.

Debugging tools:

  • Open a terminal, type the xev command and press Enter. Now see if you still see multiple characters when typing the command.
  • In the terminal, list all files in your home folder sorted by modification time. If your .bashrc got modified lately, then that would be a good candidate file to check out. The command is: ls -latr (newest file on the bottom). You could also check this in the graphical file browser, ensure that you configure it to show hidden files and sort by time too.
  • For hardware modifications: plug the device and receiver in a second computer and see if it is also affected by this.
7
  • Strangely, the issue fixed itself when either upgrading to Trusty or switching to UbuntuGNOME. – Alex Dueppen Apr 19 '14 at 14:26
  • Nevermind, the issue is back – Alex Dueppen Jun 1 '14 at 19:20
  • @SomeRandomUbuntuLover Have you tried the debugging steps in this answer? Since you have this bug at GRUB too, could it be that your hardware is broken? – Lekensteyn Jun 1 '14 at 20:27
  • Yes, but I ended up just changing the batteries, and that worked. – Alex Dueppen Jun 1 '14 at 20:28
  • @SomeRandomUbuntuLover Right... that could also be a problem. UPower and Solaar are supposed to report battery levels. Haven't you seen any low battery warnings? – Lekensteyn Jun 1 '14 at 20:34
0

I have a k800, brand new and it's doing this. I was way out of town for 4 months right after I bought it so can't do a store return. Logitech keeps blowing me off on resolving the problem. This definitely should be a recall issue!! Instead they're acting like it's never happened to anyone else

1
  • I ended up just fixing it once and for all by getting a warranty replacement – Alex Dueppen Jan 25 '16 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.