I am new to Ubuntu and I know there were a lot of similar issues and I've tried to follow some of the answers on the web (e.g. Dell Inspiron Wifi off or How do I get an Atheros AR8162 working?), but none of them are working, or are causing more errors along the way.

Recently I bought new Dell Inspiron 15 with installed Ubuntu 12.04 on it, but there are no options were to connect to wifi. My router is working and all other devices are seeing it.

Here is some information that you might need for advice. I'll be happy to provide anything further, please help me.

 $ iwconfig 

eth0      no wireless extensions.

lo        no wireless extensions.

$ rfkill list all
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

iwlist scan
eth0      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

lspci | grep Network
02:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

sudo lshw -class network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 07
       serial: 74:86:7a:4c:6c:b8
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:61 ioport:4000(size=256) memory:c0700000-c0700fff memory:c0400000-c0403fff
  *-network UNCLAIMED
       description: Network controller
       product: QCA9565 / AR9565 Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:c0600000-c067ffff memory:9fb00000-9fb0ffff

    lsmod | grep ath
ath9k                 133223  0 
ath9k_common           14054  1 ath9k
ath9k_hw              399752  2 ath9k,ath9k_common
ath                    24124  3 ath9k,ath9k_common,ath9k_hw
dm_multipath           23306  0 
scsi_dh                14589  1 dm_multipath
ath3k                  12918  0 
mac80211              555318  2 ath9k,b43
bluetooth             212001  25 bnep,rfcomm,btusb,ath3k
cfg80211              208382  4 ath9k,ath,b43,mac80211

Using these helped

`sudo apt-get install linux-backports-modules-cw-3.10-precise-generic

 sudo modprobe ath9k `

but not for a long time. Then I tried this advice and wifi works again:

Can't reach wi-fi signal on Ubuntu, but can do it on other OS/devices (ath9k)


Please open a terminal and run:

uname -r

Is your kernel version annotated '-pae'? If so, please get a working wired ethernet connection and then do:

sudo apt-get install linux-backports-modules-cw-3.10-precise-generic-pae

If not, then:

sudo apt-get install linux-backports-modules-cw-3.10-precise-generic

Detach the ethernet and do:

sudo modprobe ath9k

Your wireless should now be working.

It appears that you have a possibly conflicting wireless driver loading. Please open a terminal and do:

gksudo gedit /etc/modules

Remove the b43 line. Proofread carefully, save and close gedit. Now do:

sudo modprobe -r b43
sudo modprobe -r ssb

Now is your wireless working correctly?

  • Thank you so much, wireless connection is now on. I tried sudo modprobe ath9k before, but I didn't detach the Ethernet cable, apparently I was inattentive while reading previous threads. – user263570 Mar 30 '14 at 15:42
  • Glad it's working. I believe your Atheros 9565 is only covered in newer versions of ath9k. Hence, we install the backports package. – chili555 Mar 30 '14 at 16:47
  • Thanks one more time. Unfortunately after restarting I had some more issues, but sudo service network-manager restart made it work. – user263570 Mar 30 '14 at 19:18
  • The problem repeated once more after rebooting my system. Only bluetooth in the list rfkill list all 3: hci0: Bluetooth Soft blocked: no Hard blocked: no – user263570 Apr 12 '14 at 17:12
  • Did the driver load? lsmod | grep ath – chili555 Apr 12 '14 at 18:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.