I bought USB 3.0 flash drive Kingston DT R3.0 (http://usb.userbenchmark.com/Kingston-DataTraveler-R30-USB-30-16GB/Rating/1435&tab=Review), but when I connected the drive to USB 3 port on my laptop i doesn't work properly. Drive is FAT32.

  • Ubuntu mounts the drive on USB 3.0 port, but when I try to copy something, copy operation freezes and drive disappears.
  • If I connect the drive to USB 2.0 port, everything works just fine.
  • If I format drive to NTFS/Ext4 (basically anything else then FAT32) the drive works with USB3.0 and USB2.0 port as well.

I need to use FAT32, because I use the drive on multiple machines (Ubuntu, Windows, SmartTV, my car radio,...)

Any ideas why my Ubuntu 13.10 doesn't read FAT32 on USB 3.0 port from this Flash drive...???

1 Answer 1


It is most likely a firmware or driver issue. If it is working over USB 2.0, then at least you can still copy files. To help diagnose the problem, have you tried the drive in Windows over USB 3.0? If it fails there, then it is most likely:

  1. The drive
  2. The USB 3.0 port
  3. The USB 3.0 controller
  • USB 3.0 port is OK, it works with other USB 3.0 disks I have... so I tried same flash drive but I installed ubuntu 14.04 with kernel 3.13.7 - and it works... so I think it's kernel 3.12.13 or ubuntu 13.10 issue... I'll upgrade to Ubuntu 14.04 soon anyway... so problem will be solved...
    – Daniel
    Mar 30, 2014 at 14:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .