I just installed 14.04 Trusty Tahr (Beta).

When running XBMC (Gotham nightly build) on in and using my LIRC remote control I noticed that only the arrow keys and Volume keys (including mute) work. All the other keys don't.

It's a standard MCE remote control, and the receiver is connected by USB. I got them both in a package and the remote control was manufactured by Linksys and the receiver by HP (or at least so it's written on them).

I tried testing the configuration by running gnome-lirc-properties but it won't start (missing module glade, and still missing it after I installed glade).

Then I tried testing for inputs by running irw but it also won't run because it is looking for configuration files or stream files that aren't there. The same goes for running lircd, which I find weird as I saw the remote is partially working, meaning there is something there that reads its inputs.

What else do I need to check and/or how can I configure the default IR support that came out of the box?

  • Try installing libglade2-0 and libglade2-0-dev. – Seth Mar 31 '14 at 1:12

You might try reconfiguring lirc with sudo dpkg-reconfigure lirc and reset the controller type through that, and also check out the XBMC guide for lirc configurations.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.