3

I am using xubuntu 13.10 right now and I have some Internet problems. When I use apt-get it takes almost forever to download just a few kBytes. I get results like these and it pauses there for a long time:

jens@Ultrabuch:~$ sudo apt-get update
[sudo] password for jens: 
Ign http://extras.ubuntu.com saucy InRelease
Holen: 1 http://extras.ubuntu.com saucy Release.gpg [72 B]                     
OK   http://extras.ubuntu.com saucy Release                                    
OK   http://extras.ubuntu.com saucy/main Sources                               
OK   http://extras.ubuntu.com saucy/main amd64 Packages                        
OK   http://extras.ubuntu.com saucy/main i386 Packages                         
Ign http://extras.ubuntu.com saucy/main Translation-de_DE                      
Ign http://extras.ubuntu.com saucy/main Translation-de                         
Ign http://extras.ubuntu.com saucy/main Translation-en                         
Ign http://archive.canonical.com saucy InRelease                               
OK   http://archive.canonical.com saucy Release.gpg                            
OK   http://archive.canonical.com saucy Release                 
OK   http://archive.canonical.com saucy/partner amd64 Packages                 
OK   http://archive.canonical.com saucy/partner i386 Packages   
Ign http://archive.canonical.com saucy/partner Translation-de_DE
Ign http://archive.canonical.com saucy/partner Translation-de   
Ign http://archive.canonical.com saucy/partner Translation-en   
96% [Verbindung mit archive.ubuntu.com (2001:67c:1360:8c01::18)

It appears to me that these freezes are caused by "Translation" packages, they are always ignored. I tried to change the server as well, that didn't work either, as can be seen below.

When I reload synaptic I get this message:

Could not download all repository indexes

The repository may no longer be available or could not be contacted because of network problems. If available, an older version of the failed index will be used. Otherwise, the repository will be ignored. Check your network connection and ensure the repository address is correct in 'Repositories' under 'Settings'.

Failed to fetch http://archive.canonical.com/ubuntu/dists/saucy/InRelease
Some index files failed to download. They have been ignored, or old ones used instead.

I'd be very happy if someone could help me with that!

Best regards, Jens

Output of ifconfig -a:

eth0      Link encap:Ethernet  Hardware Adresse 50:b7:c3:07:35:1e  
          UP BROADCAST MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:0 (0.0 B)  TX-Bytes:0 (0.0 B)

lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:65536  Metrik:1
          RX-Pakete:2440 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:2440 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:211909 (211.9 KB)  TX-Bytes:211909 (211.9 KB)

wlan0     Link encap:Ethernet  Hardware Adresse c8:f7:33:11:38:70  
          inet Adresse:192.168.2.105  Bcast:192.168.2.255  Maske:255.255.255.0
          inet6-Adresse: fe80::caf7:33ff:fe11:3870/64 Gültigkeitsbereich:Verbindung
          inet6-Adresse: 2003:66:8807:c620:456b:7fc9:1041:7cc9/64 Gültigkeitsbereich:Global
          inet6-Adresse: 2003:66:8807:c620:caf7:33ff:fe11:3870/64 Gültigkeitsbereich:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:28809 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:18907 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:32338097 (32.3 MB)  TX-Bytes:3088377 (3.0 MB)

Partial output of apt-fast:

Hit http://ftp-stud.hs-esslingen.de saucy-security/restricted Translation-en
Hit http://ftp-stud.hs-esslingen.de saucy-security/universe Translation-en
Ign http://ftp-stud.hs-esslingen.de saucy-backports/main Translation-en_GB     
Ign http://ftp-stud.hs-esslingen.de saucy-backports/main Translation-de        
Ign http://ftp-stud.hs-esslingen.de saucy-backports/multiverse Translation-en_GB
Ign http://ftp-stud.hs-esslingen.de saucy-backports/multiverse Translation-de
Ign http://ftp-stud.hs-esslingen.de saucy-backports/restricted Translation-en_GB
Ign http://ftp-stud.hs-esslingen.de saucy-backports/restricted Translation-de
Ign http://ftp-stud.hs-esslingen.de saucy-backports/universe Translation-en_GB
Ign http://ftp-stud.hs-esslingen.de saucy-backports/universe Translation-de
Ign http://ftp-stud.hs-esslingen.de saucy-security/main Translation-en_GB
Ign http://ftp-stud.hs-esslingen.de saucy-security/main Translation-de
Ign http://ftp-stud.hs-esslingen.de saucy-security/multiverse Translation-en_GB
Ign http://ftp-stud.hs-esslingen.de saucy-security/multiverse Translation-de
Ign http://ftp-stud.hs-esslingen.de saucy-security/restricted Translation-en_GB
Ign http://ftp-stud.hs-esslingen.de saucy-security/restricted Translation-de
Ign http://ftp-stud.hs-esslingen.de saucy-security/universe Translation-en_GB
Ign http://ftp-stud.hs-esslingen.de saucy-security/universe Translation-de
98% [Connecting to archive.canonical.com (2001:67c:1360:8c01::16)]>

closed as off-topic by Seth Dec 25 '14 at 1:07

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Could you add the output of ifconfig -a to your question? – s3lph Mar 28 '14 at 16:49
  • Where are you from and which is your provider? 'cause I have similar issues with Kable Deutschland. – dadexix86 Mar 28 '14 at 16:52
  • I am from Germany and I use Deutsche Telekom. I had DSL 16 with a different router before and I didn't have these problems with xubuntu. – heyjay Mar 28 '14 at 16:56
  • Sure that DT has no disruption in your area? – Gx1sptDTDa Mar 29 '14 at 17:00
  • Not to my knowledge. Downloads are constantly fast. apt-get freezes every time I have tried so far. – heyjay Mar 29 '14 at 20:00
0

First: Ign is ok - it means that repo has not changed since last check and no indexes need to be downloaded.

It seems you accessing ubuntu repo through ipv6, have you noticed any problems with other ipv6 enabled hosts?

You may use ping6 or traceroute6 for quick check of latency and packets loss (although you should remember that TCP and ICMP traffic may be treated differently by your ISP or intermediate hosts), i.e.

ping6 -c20 -i0.5 archive.canonical.com

Packets loss or high time indicates that you have some network problems.

Try to compare it to ICMP via ipv4:

ping -c20 -i0.5 archive.canonical.com

If problem seems to be network-related, try to get rid of ipv6 and check if it helps. You may just delete ipv6 address from your network interface (with DHCP it will be reassigned after reconnect, so it's safe to do so):

sudo ip addr del 2003:66:8807:c620:456b:7fc9:1041:7cc9/64 dev wlan0
sudo ip addr del 2003:66:8807:c620:caf7:33ff:fe11:3870/64 dev wlan0

Also you may check how repo works in browser or try to download something using curl/wget or similar low-level tool (choose single-threaded tool), for example

wget http://archive.ubuntu.com/ubuntu/dists/saucy-updates/Contents-i386.gz

If you'll get much higher download speed with browser/wget than with apt - it may be some problem related to apt.

0

Apt-fast is a script that can "drastically improve APT download speed" by using command line download accelerators such as Axel or Aria2 with multiple connections per package.

Ubuntu users can install the latest stable apt-fast from its official PPA:

sudo add-apt-repository ppa:apt-fast/stable
sudo apt-get update
sudo apt-get install apt-fast

apt-fast configuration:

When installing apt-fast in Ubuntu via its PPA, the package asks you if you want to use aptitude or apt-get, what download manager to use (axel or aria2c). If, later on, you want to change some of the apt-fast options, use the following command:

sudo dpkg-reconfigure apt-fast

aria2c is the download tool recommended by the apt-fast developers, mostly because it supports resuming downloads.

Using apt-fast:

apt-fast works the same as apt-get and all you have to do is use "sudo apt-fast install PACKAGE" instead of "apt-get" and so on for any operation.

Install a package:

sudo apt-fast install PACKAGE

Upgrade packages:

sudo apt-fast upgrade

Install the build dependencies for a package:

sudo apt-fast build-dep PACKAGE

Like I was saying, the commands are identical to apt-get and all you have to do is replace "apt-get" with "apt-fast". There's also a download command ("apt-fast download PACKAGE") which downloads the binary into the current directory.

  • Thanks for your help! As I noticed earlier I haven't had this problem before, apt-get always ran pretty fast even though I had a slower Internet connection. I am not a pro but I can imagine that the problem lies in the connection to some servers or wifi settings maybe. – heyjay Mar 28 '14 at 19:26
  • Is the connection slow down only when using apt-get or software center? – Wild Man Mar 29 '14 at 3:37
  • Yes, I think so! – heyjay Mar 29 '14 at 16:46
  • Does apt-fast have the same problem as apt-get ? – Aniruddha Mar 29 '14 at 17:37
  • Yeah, apt-fast doesn't work for me. I've updated the question to post the output of that. – heyjay Mar 29 '14 at 20:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.