2

I have a huge problem here.

As I turn on my laptop, I reach the session login splash screen. I select my user name, but straight after my desktop is loaded, a really quick message appears (too quick to read it) and I'm logged out...

I guess something is wrong in a script that should be loaded on startup, but I don't know how to debug that...

Where can I find the logs of session opening?

I tried script filename to register in another console, but that did not work, I tried to edit ~/.config/lxsession/Lubuntu/desktop.conf but without success either.

Any advice will be appreciated! Thanks

I'm using Lubuntu 13.10


EDIT

Thanks @Ash for reply. Here my /var/logs/Xorg.0.log file extract, looks like an error there:

(EE) BUG: triggered 'if (priv->num_active_touches == 0)'
(EE) BUG: ../../src/synaptics.c:2658 in UpdateTouchState()
(EE) 
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x3d) [0x7f5ced093fdd]
(EE) 1: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f5ce4524000+0x2c74) [0x7f5ce4526c74]
(EE) 2: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f5ce4524000+0x4b40) [0x7f5ce4528b40]
(EE) 3: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f5ce4524000+0x6752) [0x7f5ce452a752]
(EE) 4: /usr/bin/X (0x7f5cecef1000+0x91ee8) [0x7f5cecf82ee8]
(EE) 5: /usr/bin/X (0x7f5cecef1000+0xba930) [0x7f5cecfab930]
(EE) 6: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f5cebff1000+0xfbb0) [0x7f5cec000bb0]
(EE) 7: /lib/x86_64-linux-gnu/libc.so.6 (__select+0x33) [0x7f5ceacfdde3]
(EE) 8: /usr/bin/X (WaitForSomething+0x19c) [0x7f5ced09159c]
(EE) 9: /usr/bin/X (0x7f5cecef1000+0x54fb1) [0x7f5cecf45fb1]
(EE) 10: /usr/bin/X (0x7f5cecef1000+0x447ba) [0x7f5cecf357ba]
(EE) 11: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf5) [0x7f5ceac2cde5]
(EE) 12: /usr/bin/X (0x7f5cecef1000+0x44aff) [0x7f5cecf35aff]
(EE)

I googled this error, and I don't have the feeling it's related to the problem I have though...

3
  • So you can get to a terminal okay? Can you check /var/log/Xorg.0.log and see if there is anything that looks like an error? – Ash Mar 28 '14 at 10:49
  • Updated my question with log extract. – Augustin Riedinger Mar 28 '14 at 11:11
  • Hmm, it doesn't look like a happy log, but as you say I'm not sure it's related or how to go about fixing it. There is a question with similar symptoms (askubuntu.com/questions/223501/…) but it's Ubuntu, not Lubuntu, so not sure if any of the suggested answers apply. Not sure what things you could try sorry, hopefully someone else can suggest something! – Ash Mar 28 '14 at 12:51
2

I finally fixed it.

I found some post on the internet that recommended to have a look at: ~/.cache/lxsession/Lubuntu/run.log

which contained some nasty error messages but started with this:

** Message: utils.vala:85: System system path location : ~/.config/lxsession/Lubuntu/desktop.conf
** Message: utils.vala:89: Final file used :  ~/.config/lxsession/Lubuntu/desktop.conf

and on the previous day, I had been changing config in lxsession-default-apps which writes things in this exact same file: ~/.config/lxsession/Lubuntu/desktop.conf

So I moved this file somewhere else, and the next startup worked. A new ~/.config/lxsession/Lubuntu/desktop.conf was generated and I am good to go.

Though it is really bad that things crash this way just by changing settings into a lxde program... But I don't know exactly what was the source of the problem so I can't really make a bug report.

Thanks for support!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.