Hi I have just installed ubunutu on my intel nuc with a celeron n2820 processor. I am not getting any sound over hdmi. I have tried installing to pulse audio app with no luck.

  • Have you tried running alsamixer, to see if the HDMI audio device is active? I normally install and run pavucontrol to use Pulse Audio for configuration, not sure if that's what you did? – Ash Mar 28 '14 at 11:00
  • I have run alsammixer and here is the result imgbox.com/FOBwNxFg – albany Mar 28 '14 at 13:15
  • I am not sure whether this could be an issue with the bios? – albany Mar 28 '14 at 13:15
  • It's been a while since I've used Alsa, I think you need to press F6 and select the HDMI device and make sure it's enabled? – Ash Mar 28 '14 at 23:35
up vote 2 down vote accepted

Ok so here is the fix I found for the nuc. Sound over HDMI works no problem after this:

sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily
sudo apt-get update
sudo apt-get install oem-audio-hda-daily-dkms

Thank you for your help!

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.