My PC with Ubuntu 13.10 is set to suspend after 30 minutes of inactivity. Up until it suspends I can resume working at any time using my Logitech K400r wireless USB keyboard.

The OS defect/problem is that once it suspends - the wireless keyboard can no longer wake the suspended Ubuntu 13.10. This appears to be a Ubuntu specific problem because the same PC when booted up with MS Windows 7 always wakes up from sleep mode when you press any key on the Logitech keyboard.

I imagine something in Ubuntu is causing the USB to go into a different state from what Windows 7 puts it in. Does anyone have any ideas how to overcome this issue as the only way to wake the PC is to walk up to it and push the power button for a short period once.

While this power button wakes up the PC it then displays a number of error messages about sound, networking etc being down ....which do go away after a few minutes of what seems to be the OS recovering from Suspend. Not sure if this is normal Linux behaviour due to my short experience with this OS.

Again could anyone help with some details on whether there is any setting that would help keep the wireless usb keyboard alive just enough to wake the pc?

Many thanks.

  • Just wondering if you got a solution for this? I just installed Ubuntu 13.10, and new to Linux. I've got the same keyboard and if the computer goes to sleep its a power button restart for me.... Any help or recommendations would be greatly appreciated. ReadyRock... – user267517 Apr 10 '14 at 15:10
  • No resolution yet. – eastavin Apr 22 '14 at 2:00
  • Having this same issue. I've enabled the USB hub in /proc/acpi/wakeup, setup a /udev/rules.d entry to enable it as a wakeup device in /sys/usb, and a host of other solutions I found online. Nothing has yet worked. – XBigTK13X Jul 14 '14 at 20:45

I found an open source project that provides extra functionality for devices on the Logitech Unified Receiver. Installing that application and a udev rule from a fork of that project allows me to wake Ubuntu 14.04 from suspend using a wireless Logitech keyboard.

Install solaar from the (now) author's PPA.

sudo apt-add-repository ppa:daniel.pavel/solaar
sudo apt update
sudo apt install solaar

If you don't have git, install it

sudo apt-get install git

Clone the fork with a corrected /udev rule

git clone https://github.com/3v1n0/Solaar.git ~/solaar

Install the /udev rule that will enable resume via the unified receiver

cd ~/solaar/rules.d

At this point, I unplugged the receiver and plugged it back in (as per instructions on the repo). Next, I launched solaar through the Dash and verified that my keyboard was communicating with the app. Finally, I rebooted and tested the Sleep button on the keyboard. After the machine was asleep, I was able to resume using any key.

  • 1
    Thanks for taking the time to look into this. I still have this problem which followed me in the upgrade to 14.04. Having limited experience with Linux... do I just follow your steps in Terminal mode to get to a resolution?.. typing the commands one at a time? I would not know if I have GIT... so I imagine there is no harm in following your command to install it again if I have it? Thanks – eastavin Jul 16 '14 at 3:13
  • 2
    I followed your instructions and entered the commands and they appeared to work. Except for the second last one.. cd ~/solaar/rules.d - it only works when you use cd solaar/rules.d I do have one other question though... how do you start this app from the dash? Sounds like it should be obvious but I cannot find anything listed that sounds like this solution? – eastavin Jul 18 '14 at 15:08
  • After running all of the commands, you should be able to run "Solaar" from the dash. – XBigTK13X Jul 21 '14 at 20:26
  • 1
    I thought I ran all the commands. The dash does not find any app called Solaar. Is there are some other way to trigger it or should I retype all the commands from the very beginning? Many thanks – eastavin Aug 13 '14 at 4:13
  • To see Solaar in the dash, after the first command run: sudo apt-get update;sudo apt-get install solaar – tomyo Apr 14 '15 at 20:39

Your question may have been answered in this forum thread: http://ubuntuforums.org/showthread.php?t=1938480

While I didn't try making the udev rule, I was able to get my machine to wake from suspend from the Logitech keyboard (K340) and mouse (M505) on the unifying receiver. In my case, I had to put the word enabled in the file /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/power/wakeup.

But what I'd really like is wake from keyboard, but not mouse. Maybe I can do that by separating keyboard and mouse to separate receivers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.