I was dual booting winodws 8.1 and ubuntu 13.10. I have updated my windows BIOS. After that i am always getting into windows. GRUB menu is not displayed.

So, Using UBUNTU 12.10 live CD (But i have 13.10 in my lap), i have repaired the boot to fix this issue.

When i clicked Boot repair, it says "UEFI is detected" I have choosen the recommended repair and it ends up with some commands

sudo chroot "/mnt/boot-sav/sda7" dpkg --configure -a
sudo chroot "/mnt/boot-sav/sda7" apt-get install -fy
sudo chroot "/mnt/boot-sav/sda7" apt-get purge -y --force-yes grub*shim-signed linux-signed*

After that, On clicking forward in the boot repair, got some error message like "GRUB is still present. Please try again"

PASTEBIN Ref: http://paste.ubuntu.com/7164372/

BIOS Settings: Secured Boot: Disabled OS Type: UEFI

Kindly help guys.


  • It looks like it may have purged the signed UEFI grub & kernels which are only required if you have secure boot on. If you go into UEFI can you not choose to boot ubuntu entry or with one time boot key boot ubuntu entry? With 8.1 you cannot boot Windows from grub if secure boot is on, some new 'feature' in 8.1 that grub does not yet have a work around for.
    – oldfred
    Mar 27, 2014 at 19:49
  • @oldfred thanks for the quick reply. BTW, i have disabled the secured Boot from the BIOS. I was dualbooting without any problem for along,only after updating the BIOS i was getting this problem. can you please let me know whether advanced boot repair(help.ubuntu.com/community/Boot-Repair) or this link - askubuntu.com/questions/88384/… helps?
    – Cyborgz
    Mar 27, 2014 at 19:53
  • Your BootInfo report showed a grub installed to gpt's protective MBR for BIOS boot. Did you somehow convert back to trying to boot in BIOS mode which would not work once changed to UEFI boot. And since Windows is UEFI you want Ubuntu in UEFI boot mode.
    – oldfred
    Mar 27, 2014 at 20:06
  • @oldfred. I have configured Secured Boot -> Disabled and OS Mode Selection -> UEFI. When tried to select Ubuntu as boot priority,always greeted with "unknown file system . Grub Resue" message got displayed. is live CD version need to be same as ubuntu installed in lap? cos,am using 12.10 in cd wheres 13.10 installed in lap. please help me out. i am totally stucked up. :(
    – Cyborgz
    Mar 27, 2014 at 20:13
  • It is better to always have repair (Windows) or live version (Ubuntu) CD or flash drives that is same version as install. Always update repair flash drives if you upgrade. But Boot-Repair often chroots into your system and downloads from correct repository, so it may work. If system is so new as to have Windows 8.1, you may be better off with 14.04, but it will not be official for another couple of weeks. Some are reporting good results with those very new UEFI hardware systems.
    – oldfred
    Mar 28, 2014 at 0:44

4 Answers 4


Not sure if this is even still an issue for you at this point but I was having the same trouble using boot-repair to purge and reinstall grub on ubuntu 14.04. So just in case someone else is having this issue here is what I did.

After I ran the last command (sudo chroot "/mnt/boot-sav/sda7" apt-get purge -y --force-yes grubshim-signed linux-signed) and attempted to click the forward button I got the message GRUB is still present. Please try again.

So I looked over the terminal output for that command and it turns out that the command was uninstalling grub*-common but was also installing grub-common:i386, which was then detected by boot-repair. So I uninstalled grub-common:i386, which then reinstalled grub-common, grub-pc etc. Rather annoying that apt-get is this stubborn when it comes to grub imo.

So in order completely uninstall grub I had to modify the command to sudo chroot "/mnt/boot-sav/sda7" apt-get purge -y --force-yes grub*shim-signed linux-signed* grub-common:i386 and once finished I was able to proceed with the boot repair.

  • 3
    Thanks for posting, this was really helpful. I had to manually uninstall grub-common with sudo apt-get remove grub-common, which got me past the error.
    – Luke Bayes
    Mar 20, 2020 at 22:52
  • 1
    Thanks!! Your answer was very helpful to find out the problem. In my case I had to remove grub-common:i386 from that partition (more details in my answer)
    – Genarito
    May 27, 2021 at 13:57

I ran into this problem today, and it turns out the last line sudo chroot "/mnt/boot-sav/sda7" apt-get purge -y --force-yes grub*shim-signed didn't run. So I pressed enter again and everything worked.


When trying to update 16.4 grub while using 21.04 I got this error. Copy pasted the command it was trying to run in a separate terminal and ran it:

sudo chroot "/mnt/boot-sav/sda1" apt-get purge -y --force-yes grub*shim-signed linux-signed* grub-common:i386

Then boot-repair asked to copy paste another command to install grub. There in I chose /dev/sda and installed grub. Then was able to remove the usb drive (live cd) and reboot to see grub smiling back at me.

All this because I installed windows after installing ubuntu. MS is starting to show some respect to Linux with native subsystem for Linux but it's ridiculous that it still ignores ubuntu at the boot/grub level.


In my case I run the same commands but with the sda4 partition (so don't just copy and paste):

sudo chroot "/mnt/boot-sav/sda4" dpkg --configure -a
sudo chroot "/mnt/boot-sav/sda4" apt-get install -fy
sudo chroot "/mnt/boot-sav/sda4" apt-get purge --allow-remove-essential -y grub*-common shim-signed

But when I run the last one I got this:

Reading package lists... Done Building dependency tree... Done Reading state information... Done Note, selecting 'grub2-common' for glob 'grub-common' Note, selecting 'grub-common' for glob 'grub-common' Package 'grub-common' is not installed, so not removed. Did you mean 'grub-common:i386'? Package 'grub2-common' is not installed, so not removed. Did you mean 'grub2-common:i386'? Package 'shim-signed' is not installed, so not removed 0 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.

Note that the command was trying to remove grub-common but there was installed grub-common:i386. So I run the same command adding that version to the end:

sudo chroot "/mnt/boot-sav/sda4" apt-get purge --allow-remove-essential -y grub*-common shim-signed grub-common:i386

The output said that the package had been removed successfully and I could continue with boot-repair

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.