So I feel really bad for asking this question because it looks like it has been asked a million times on the internet. I am even finding a very consistent answer, and I am not getting any errors when I try the solution I found, but it is still not working.

Here is the issue. I have an ntfs partition on an external hard drive that I do not want to mount on startup (sound like a freaking common problem or what?).

I have found this question asked all over the internet, and the single answer that comes back pretty much unanimously is I should be using the "noauto" option in fstab for the device. Even the man pages for fstab states:

"noauto do not mount when "mount -a" is given (e.g., at boot time)"

Sounds like that is what I want right?! Well I am using that option and the drive is still mounted by the time I log into my account.

Here are my fstab entries for the 2 partitions that are on the same external drive:

#External 2TB drive
UUID=8598c4fc-171a-4324-a4d3-06145d12ceba /media/Storage   ext4    errors=remount-ro 0       2
#Windows compatability partition on external drive does not need to be mounted.
UUID=751E843A54B3D902 /media/Windows\040Compatability     ntfs    noauto     0        0

I am at a total loss for why the noauto option is not working like I expect it to, but when I start up my pc the drive is available and mounted at the location specified (/media/Windows Compatability). I tried changing the options (like user/nouser) and those behaved as expected. Just the noauto is completely baffling me.

Thanks for any help.


PS: If you are curious about the use case, there is a 2TB ext4 partition on the drive, and then a small ntfs partition on it. The point of the ntfs is to carry some windows tools for reading ext4 when I have to use my drive on a strange machine.

  • 1
    My guess is that you are mistaken: the drive is not mounted automatically at boot time ( which is also what happens when you have no entry for it in fstab ). The shell still shows the icon for it so you can mount it by clicking on it. – psusi Mar 27 '14 at 1:47
  • I think @psusi could be right. Try to issue mount after boot and see the results. Now, if the disk is inserted AFTER boot, now it is managed by udisks --- which I think does not even look at fstab, and on a "plug" event mounts everything it sees... – Rmano Mar 27 '14 at 2:32
  • I believe it is mounted because the icon has the option to eject it before I ever click on the link (there is a little eject symbol over it just like all my other drives). Right clicking (without opening the drive) reveals the eject option and not the mount option. – gnomed Mar 27 '14 at 14:45
  • @psusi forgot to tag (and now I cant edit it) but see above – gnomed Mar 27 '14 at 14:51
  • Does it show up when you open a terminal and run findmnt? – psusi Mar 27 '14 at 18:42

Why don't you just comment the line in fstab to disable it on boot?

#UUID=751E843A54B3D902 /media/Windows\040Compatability     ntfs    noauto     0        0

You should still be able to mount he partition simply with nautilus whenever you need it.

  • That was the state of my machine before I started tinkering to solve this problem in the first place. The system automounts usb drives when there is no entry in fstab. They are mounted to /media/<username>/<drive label> – gnomed Mar 27 '14 at 14:48

If the disk is mounted by udev, try to add a file 81-hide-my-disk.rules in /etc/udev/rules.d with the content:


(strange UUID, by the way).

By the way, i think you probably need to reload udev rules after the change:

sudo udevadm control --reload-rules

Original source is on Unix-Linux SE.

I checked the language in the (current in 13.10) /lib/udev/rules.d/80-udisks.rules and it seems that it is still the same.

  • I will try this when I get home today. I am wondering how this works? Does it hide the drive from udev (so I will never be able to mount it?)? PS: I also thought it was a strange UUID. I created the partition with the same session of gparted I used to make the ext4 (and I assume gparted is what assigns the UUID on creation), so I dunno lol – gnomed Mar 27 '14 at 14:50
  • Disclaimer: my experience with udev is relative, and sometime frustrating. I think it will hide it, and that you can mount it by udisksctl mount --block-device /dev/sd<whatever>. Not sure though. – Rmano Mar 27 '14 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.