0

I have an iso file connected with the cd drive of an Ubuntu VM. Now I am trying to mount it .

I have tried mount -o loop /dev/cdrom /mnt/cdrom and it mounts properly but when I try to execute any command on the extracted file it says Mounted as readonly .

I have tried mount -o remount,rw /dev/cdrom /mnt/cdrom but it says Specify file type .

I have tried mount -t auto -o remount,rw -force /dev/cdrom /mnt/cdrom It again says Specify a file type

I have tried mount -t ext -o remount,rw -force /dev/cdrom /mnt/cdrom It says Bad option

Please let me know what I have to do to mount /dev/cdrom

0

Try these commands,

sudo umount /dev/cdrom
sudo chmod 777 /mnt/cdrom                 # Gives Read,Write,Execute permission for all who tries to access cdrom directroy
sudo mount -o loop /path/to/iso/file/YOUR_ISO_FILE.ISO /mnt/cdrom
1
  • Hey Avinash, It is saying can't find /mnt/cdrom in /etc/fstab or /etc/mtab
    – Reuben
    Mar 26 '14 at 9:21
0

When you try mount device (/dev/cdrom) it will act like device CDROM. Thus you will not able to remount it in read-write mode. I suggest you to mount ISO file (with option loop) instead then remount it in read-write mode. Or you can combine these two options:

sudo mount -o loop,rw /path/to/cd-image.iso /mnt/cdrom

However, trying this command gave me such output:

$ sudo mount -o loop,rw Install/ubuntu-10.04-dvd-amd64.iso  /mnt
mount: block device /home/karimov-danil/Install/ubuntu-10.04-dvd-amd64.iso is write-protected, mounting read-only

So, only option is left to mount/open it as archive, extract files you want to execute and execute them in filesystem mounted in read-write mode.

2
  • Hi Danatela, I have first mounted with loop then when i tried to remount I am facing error that, Cannot remount block device /dev/loop0 read-write, is write-protected .
    – Reuben
    Mar 26 '14 at 9:25
  • The only option you have is to copy needed files onto filesystem and execute them there.
    – Danatela
    Mar 26 '14 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.