3

I have received credentials for my University's network machine (Ubuntu yay!) that I have ssh access to. I would like to connect to it but first I need to connect through a gateway that I have specified in .rdp file received from my University.

On Windows I just double click on it and I have the session - first asking about domain credentials.

I have the following knowledge:

  • username
  • password
  • gateway hostname e.g. secretgateway.net
  • hostname e.g. myhost.local
  • domain name e.g. pluto
  • server port 3389

I know I can use likewise-open for connecting to windows domains but how do I specify it there since it is a remote network for me ?

EDIT after Remmina import ( there is no information about domain login nor the gateway)

enter image description here

EDIT2

I have also tried with xfreerdp :

xfreerdp /v:myhost.local /d:pluto /u:USER /p:PASS /g:secretgateway.net

and I get

transport_connect: getaddrinfo (Name or service not known) Error: protocol security negotiation failure

EDIT3

using new version of xfreerdp I get to launch my con.rdp file and I get the following

$  xfreerdp conn.rdp /p:PASS
autoreconnection enabled:i:1
devicestoredirect:s:*
drivestoredirect:s:*
redirectdrives:i:1
server port:i:3389
compression:i:1
keyboardhook:i:2
authentication level:i:0
promptcredentialonce:i:1
gatewayusagemethod:i:1
gatewayprofileusagemethod:i:1
gatewaycredentialssource:i:0
remoteapplicationmode:i:1
remoteapplicationname:s:ubuntu 12.04 v2.1 [60 GB HDD]
remoteapplicationprogram:s:||2fb6eb96-b458-11e3-92eb-00155d020101ssh_sr
full address:s:myhost.local
gatewayhostname:s:secretgateway.net
username:s:platon\wcss-d21d3q
connection type:i:5
displayconnectionbar:i:1
screen mode id:i:2
use multimon:i:1
redirectclipboard:i:1
redirectposdevices:i:0
redirectprinters:i:0
redirectcomports:i:0
redirectsmartcards:i:0
session bpp:i:32
allow font smoothing:i:1
allow desktop composition:i:1
disable wallpaper:i:0
disable full window drag:i:0
disable menu anims:i:0
disable themes:i:0
bitmapcachepersistenable:i:1
disable cursor setting:i:0
redirectdirectx:i:1
audiomode:i:0
audiocapturemode:i:0
videoplaybackmode:i:1
loading channel rail
connected to secretgateway.net:443
connected to secretgateway.net:443
Could not open SAM file!
Could not open SAM file!
Could not open SAM file!
Could not open SAM file!
rts_connect error! Status Code: 401
HTTP/1.1 401 Unauthorized
Content-Type: text/plain
Server: Microsoft-IIS/7.5
WWW-Authenticate: Negotiate
WWW-Authenticate: NTLM
WWW-Authenticate: Basic realm="secretgateway.net"
X-Powered-By: ASP.NET
Date: Wed, 26 Mar 2014 00:19:57 GMT
Content-Length: 13

rts_connect error!
rpc_connect failed!
Error: protocol security negotiation or connection failure
WaitForSingleObject: pthread_join failure: 3
1

Okay to do this you need a version of xfreerdp that is higher than in the official repo's

sudo apt-get purge freerdp

sudo apt-get install build-essential git-core cmake libssl-dev libx11-dev libxext-dev libxinerama-dev \
  libxcursor-dev libxdamage-dev libxv-dev libxkbfile-dev libasound2-dev libcups2-dev libxml2 libxml2-dev \
  libxrandr-dev libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev libxi-dev libgstreamer-plugins-base1.0-dev

git clone git://github.com/FreeRDP/FreeRDP.git

cd FreeRDP

cmake -DCMAKE_BUILD_TYPE=Debug -DWITH_SSE2=ON .
make
sudo make install
echo '/usr/local/lib/freerdp' | sudo tee --append /etc/ld.so.conf.d/freerdp.conf

Okay now you should be able to connect from the command line:

xfreerdp /v:myhost.local /d:pluto /u:USER /p:PASS /g:secretgateway.net

GUI Remmina gateway option

So this is actually being discussed as a new feature for remmina RDP plugin on github here.

There is just a problem with securley storing gateway password, as remmina's plugin architecture only allows one secret to be stored per connection. I am currently looking into fixing this for my self and if I get it finished will put a pull request in.

I have patched Remmina's rdp plugin to have a gateway field and would gladly let you have the patched version but it assumes that the gateway credentials are the same as your credentials for the target box in a lot of cases this is true.

0

There are version of FreeRDP which Remmina uses that does support an RDP Gateway, but it is buggy and I haven't gotten it to work reliably. I have only been successful connecting from the commandline using FreeRDP, but it regularly crashes on me so I consider it non-usable and go through a VPN option instead.

  • I have also managed to get it to work but the screen is somehow buggy/flickering. Non usable for me either. – Patryk Apr 30 '14 at 15:40
-1

With remote desktop client (just a frontend for rdesktop) you can select an .rdp file that you use to import all the settings to login. Maybe this will work. it's avalible trough the Ubuntu software centr (apt://grdesktop)

  • I can open the .rdp file but it won't work . – Patryk Mar 25 '14 at 23:04
  • I tried the following and this seems to work; install remmina (apt-get install remmina ,, most of the times already installed) and from the the menu tools > import select the .rdp file. After that just open it from the main window – radriaanse Mar 25 '14 at 23:29
  • 1
    The OP asked about remote desktop gateway functionality. This question doesn't address that. – flickerfly Apr 30 '14 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.