3

Continuous crackling from moment Ubuntu starts up.

When playing sound gives interruptions.

I didn't experience any sound problem in Windows before I installed Ubuntu (ubuntu is great btw).

Continuous switching between speakers and headphones in sound settings.

Crackling continues when pulseaudio turned off.

Difficulty adjusting sound levels in alsamixer.

Same problem under all linux OS.

I tried editing sample rate in daemon.conf or tsched=0 in default.pa, checking archlinux site and some basic bug solutions for ALSA,reinstalling different linux OS, but no newbie luck..

there's a short video I made of the problem: https://www.facebook.com/photo.php?v=486149771507522&l=6160322189117296858

see also more info on my system on : ALSA Information Script v 0.4.63 (for linux, kernel, alsa sound info at) http://www.alsa-project.org/db/?f=050330a52b4870e7ed9d72af30adb1a4987e7dcc

and a bug report I posted at http://www.bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1294830 : HP Compaq dc7600 Small Form Factor, Realtek ALC260, Green Line Out, Rear Underruns, dropouts or crackling sound. I received feedback on this but it's too technical for me.

thx for any advice,

bless

closed as off-topic by BuZZ-dEE, Braiam, Avinash Raj, Radu Rădeanu, Alvar Mar 26 '14 at 16:06

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – BuZZ-dEE, Braiam, Avinash Raj, Radu Rădeanu, Alvar
If this question can be reworded to fit the rules in the help center, please edit the question.

  • IS the problem also in Windows? I couldn't understand. – Mr.Lee Mar 25 '14 at 18:37
  • I didn't have sound problems in Windows before, but tired of it I made the change to Ubuntu. A little disappointed only I couldn't fix this sound problem. At the same time happy about the opportunity to learn about Ubuntu :) – Bosdwerg Mar 25 '14 at 19:03
  • So to clarify, Windows is no longer on this machine. – Mr.Lee Mar 25 '14 at 19:41
  • It isn't. I chose to make the step to open-source. – Bosdwerg Mar 25 '14 at 19:43
  • Go into alsamixer in terminal and see if you can mute the device by pressing m – Mr.Lee Mar 25 '14 at 19:46
1

Try this link. Seems to me that your system is switching between headphones and speakers. Crackling is usually caused by powering a speaker. Since the speakers are constantly being powered on and off, it would keep crackling. This package lets, you control the headphone switching.

Same package, another description

  • Thanks for your time. This seems to solve the unstable sound settings, the sound interruptions, the switching between headphones and speakers. The sound is ok now, that is sufficient enough for me. It does not however stop a continuous ticking or what I called crackling when no sound is being played. – Bosdwerg Mar 25 '14 at 21:06
  • Glad to hear that it helped somewhat. Have you tried lowering the volume to see if the crackling get lower? – Mr.Lee Mar 25 '14 at 21:11
  • Exactly. The crackling is quite soft. I hardly hear it at the amount of volume I need to hear music. When I turn the volume up, the crackling sound output increases. – Bosdwerg Mar 25 '14 at 21:14
  • My guess is that it is static. This varies from speakers and sound card. There isn't much you can do software wise if this is the case. The only tweak that might help is checking if you have an EQ (equalizer) on and disabling it or setting it to default volumes. Example of an equalizer – Mr.Lee Mar 25 '14 at 21:18
  • ok. I don't seem to have an EQ. Could you tell me why this problem occurs after installing Ubuntu and not in Windows before? – Bosdwerg Mar 25 '14 at 21:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.