30

Alt-tab seems slow, my machine has the proper drivers installed and everything else is fast except alt-tab. Setting the plugin to show icons instead of window previews doesn't help.

Is this a bug or is a way to speed this up?

  • 8
    I thought it was just my system. Good to know you can increase it! – Marco Ceppi May 19 '11 at 15:20
  • 2
    Anyone know why this is set at 2s by default? Can't imagine why that's considered useful... – David Miller May 21 '11 at 10:09
  • 1
    @David Miller, perhaps it is set to 2s to motivate users to change it, thereby discovering other Compiz settings to play with. :) – Michael Moussa Aug 14 '11 at 16:27
22

It ends up that there is a delay of 2ms set in the alt-tab switcher (called the Static Application Switcher) by default.

To change it, use you can use CompizConfig Settings Manager Install ccsm. After you install it, run it via the dash by searching for compiz or just run ccsm from alt-f2:

enter image description here

And then set Popup Window Delay to 0 in the behavior tab.

enter image description here

And crank up the speed:

enter image description here

| improve this answer | |
  • Even after setting the popup delay to 0, my alt+tab delay was still noticibly slow. Simply disabling the compositing_manager did speed things up - but this is a bit drastic. It affects (often breaks) other applications' functionality if disabled (docky, gnome-do). To disable: run gconf-editor => edit (uncheck) /apps/metacity/general/compositing_manager – michael Dec 8 '11 at 5:06
  • Does this still work in 12.04? – Patrick Marchwiak Sep 27 '12 at 3:28
  • Seems to work in 12.10 as well. Although, you need to install compiz-plugins first (askubuntu.com/questions/208375/…) – Mika Vatanen Nov 10 '12 at 22:19
  • Just following the screenshots without reading anything helped me solve this :) thanks! – Christian Vielma Oct 4 '14 at 19:33
15

12.10

  1. Requirements: You will need Compiz Config Settings Manager (CCSM).

    sudo apt-get install compizconfig-settings-manager
    

    You may also need the Compiz Plugins too. The compiz plugins were included in compizconfig-settings-manager in earlier versions of Ubuntu

    sudo apt-get install compiz-plugins
    
  2. Enable Static Application Switcher

    CCSM > Window Management > Static Application Switcher > Check the box to enable it.

    2.1 You will be prompted with a "bindings conflict" dialogue. Select Resolve conflicts.

    enter image description here

    2.2 Now you will be prompted with this monstrosity:

    enter image description here

    Select yes to disable any and all conflicts. Which one is yes? The third option, furthest to the right, it will always be the third option furthest to the right.

    You will now get a weird Application Switcher when you Alt+Tab. It will look like you've broken everything. Next we'll configure it.

  3. Go to CCSM > Window Management > Static Application Switcher >

    3.1 Bindings

    CCSM > Window Management > Static Application Switcher > Bindings

    • Ensure the Next window binding is set to Alt+Tab
    • Ensure the Prev window binding is set to Shift+Alt+Tab
    • Ensure the Next window (All windows) binding is set to Control+Primary+Alt+Tab
    • Ensure the Prev window (All windows) binding is set to Shift+Control+Primary+Alt+Tab
    • Ensure all the binding above are disabled in the CCSM Ubuntu Unity Plugin (UUP). The binding for UUP can be found in CCSM > Ubuntu Unity Plugin > Switcher.

    The Static Application Switcher Bindings should like something like this:

    enter image description here

    And the Ubuntu Unity Plugin Bindings should look something like this (notice that the first 4 bindings are disabled, because we're using the static application switcher):

    enter image description here

    3.2 Behaviour

    CCSM > Window Management > Static Application Switcher > Behaviour

    • Speed = 50.0000

    • Timestep = 10.0000

      Timestep is how often the window's direction is recalculated. A high timestep will result in windows that overshoot their position and bounce back, and a low timestep will result in windows that drift slowly and accurately to their position. - http://wiki.compiz.org/Plugins/Scale

    • Popup Window Delay = 0.0000

      enter image description here

    3.3 Appearance

    CCSM > Window Management > Static Application Switcher > Appearance

    • Show icon only = Yes:Checked

      enter image description here

Done! Alt+Tab should be much faster.

| improve this answer | |
  • great answer & info! Was actually only looking for a clear definition of "Timestep" of said plugin... a very clear n helpful post! thx indeed!! – nutty about natty Jan 19 '13 at 23:12
  • PS: what does "auto change viewport" exactly mean/do? the tooltip leaves me guessing... and google doesn't want to pop the answer, either. – nutty about natty Jan 19 '13 at 23:15
  • This worked for me on 12.04 as well. Thanks very much. – Drew Noakes Mar 31 '13 at 23:06
  • Great! Thanks for the detailed explanation. I honestly can't believe how slow the default Ubuntu application switcher is. – friederbluemle Sep 15 '15 at 2:11
1

"Quick Alt-Tab" switches between two upper windows in stack of many windows. Try to open many windows and press Alt-Tab quickly, not waiting for appearance of graphical "windows picker". Obviously small delay is to enable this feature.

| improve this answer | |
  • "Obviously small delay is to enable this feature." Your reasoning doesn't make sense to me. Even if you wait, you'll still switch between the two windows at the top of the stack of windows. – Detached Laconian Sep 16 '18 at 18:38
0

Changing the popup window delay won't change the speed at which the applications switch. On the same settings page as in your answer, change 'Speed' from the default 4 to 1. That sped things up a lot on my setup.

| improve this answer | |
  • Changing speed to 1 made it real slow to me, however when I cranked it to 50 it's basically instant. (Updated my answer) – Jorge Castro May 19 '11 at 17:59
  • The speed property only affects the animation of the selection box within the popup. No matter what, the selected window will switch instantly each time you hit tab (after the popup delay,) but the box itself will get left behind at slow speeds. This becomes obvious if you go to the Appearance tab, twirl out select window highlight, and for highlight mode, choose bring selected to front. – Dorkus1218 May 19 '11 at 18:28
0

It is the "window manager" that introduces these delays. If you have installed ubuntu-mate-desktop on top of Ubuntu 16.04, you can run mate-tweak to allow selection of an alternate window manager.

For a low-latency experience, try "Marco (No compositor)".

To do this from the command-line run:

marco --no-composite --replace

enter image description here

| improve this answer | |
  • On my system (Ubuntu MATE 16.04), "Marco (Software compositor)" was activated and the 2 seconds delay when pressing Alt+Tab was there. After I switched to Compiz the delay disappeared and I have fancy window effects now. – Michael Kremser Aug 20 '17 at 12:07
  • @MichaelKremser: Yes, that is what I experienced too. My solution was to switch from software compositor to No compositor. Using Compiz is another way to go, and may work fine for you. If you run into other weird problems, try switching back to Marco. – nobar Aug 21 '17 at 2:33
  • I want to upvote myself. Ubuntu MATE 18.04 still requires this change in order to be snappy on some of my hardware. It also affects switching between workspaces -- which for me was a bigger problem than alt-tab. – nobar Nov 29 '18 at 22:55
  • Maybe it's just my imagination, but it feels like even regular typing is just a tad more responsive when the compositor is disabled -- it's like I've been walking in sand and just got onto solid ground. – nobar Nov 29 '18 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.