0

I'm running Ubuntu 12.10 with PHP Version 5.4.6-1ubuntu1.7. I have tried the standard instructions to install sdo: http://us2.php.net/manual/en/sdo.installation.php as well as the instructions in the comments on: https://bugs.php.net/bug.php?id=58951.

I even tried this unofficial version on Github: https://github.com/CloCkWeRX/sdo.

(I also tried all of the above with a newer PHP version - 5.5.9+dfsg-1+sury.org~quantal+1 from https://launchpad.net/~ondrej/+archive/php5)

All methods error out during make. I am trying to install this so that I can use an UPS's API for shipping methods. Any help is greatly appreciated!

0

I finally worked out a solution to install sdo on Ubuntu 12.10. First, I downgraded PHP to the 5.3.x series, using this script and instructions from here: http://www.ubuntugeek.com/how-to-downgrade-php-version-from-5-4-to-5-3-in-ubuntu-12-10-quantal.html

Next, I downloaded a patched version of sdo from here: https://pety.homelinux.org/cloudbank_repo/SCA_SDO-1.2.5.tgz

Finally, I patched the code as follows:

Edit sdo.cpp - remove all "static" modifiers, except "static char rcs_id[]..."

Edit commonj/sdo/SDODataConverter.cpp - add "#include <stdio.h>"

and then I simply ran the usual commands to compile:

phpize
./configure
make
make install

Then I verified that sdo was compiled in by visiting phpinfo.php on my server, and all was working: sdo section from phpinfo() output

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.