52

After activating full screen view for a virtual machine in virt-manager there is no obvious way to un-full screen. Any ideas?

10 Answers 10

9

Alt+F10 or Alt+drag down with your mouse.

55

Neither of the existing answers worked for me when running a VM in fullscreen using 12.04.

If you look at the top center of the screen, you can see a little sliver of white. Hover the mouse over that sliver and it will reveal two icons: an "unfullscreen" on the left, and a "send key combo" on the right. You may have to ungrab by pressing Ctrl-Alt momentarily before it will come up. Click the "unfullscreen" to get back to a windowed view.

  • In 16.04 the problem with the invisible/unreachable "unfullscreen" icon can be solved by switching the display to spice. This fixes the bug for me. – jerico Jun 11 '17 at 16:44
15

When in full screen mode, hit Ctrl+Alt to 'unhinge' the mouse and move the mouse to the top-middle of the screen. A little applet drops down to allow you to leave full screen and send key-combinations.

  • It also works on RedHat 6. – Ivan Chau Apr 24 '14 at 3:44
13

Ctrl+Alt+F Is the toggle switch for the top center menu bar.

If you see no menu bar in the top center after a slight over

Toggle it on with

Ctrl+Alt+F

And try again

  • I tried every "solution" and this is the only one that works for me. The key combo toggles fullscreen mode outright, not the menu bar. I'm using raw qemu v2.10.50 (git) with the built-in gtk3 GUI and -vga virtio -display gtk,gl=on. – CR. Oct 27 '17 at 12:54
  • confirmed for qemu (it's actually hinted on View menu items) – user359096 Jul 2 '18 at 6:24
3

Had the same problem with osx today. I found out that if you hover the mouse in the top middle of the screen where the white bar is supposed to be, even though it doesn't show up long enough to actually click on it, you can use ctrl+alt+arrow keys to move to other workspaces while the mouse is there.

  • 1
    Same for Ubuntu 16.04 with Compiz and Multi Screens. The small bar does not show up, sometimes only some white flash can be spotted for a microsecond, if contrast permits. The sad thing is: It only pops out when the mouse hits the border. However the buttons are a bit lower, so moving the mouse along the top while clicking does not work. So you have to: Find the middle. Bump the mouse against the top border. Move the mouse down at least 2 pixels. Click there, blindly. If you hit the invisible left button you leave fullscreen, on the right one a dropdown with the special keys is shown. – Tino Aug 7 '16 at 9:34
  • In 16.04 this problem is solved in the spice viewer. – jerico Jun 11 '17 at 16:45
1

It don't seems there is any keywords set for this action and on Kubuntu 12.04 (KDE 4.9.5), none of given keyboard shortcuts worked for me.

Trick to make the Thin-bar pop-out

If you struggle to make the tiny toolbar pop-out, here is a how to do it :

  1. focus another windows (click it) ;
  2. then hover the thin-toolbar ;
  3. click when it pop-out

If virt-manager has the focus, I can't get the toolbar to show up.

Roadmap

The full-screen issue should be addressed in the coming release as state on the project roadmap :

Proper fullscreen mode -- Currently the VNC fullscreen mode leaves a menu bar at the top of the screen which sucks for numerous reasons. It would be great if we could use the hiding toolbar 'autoshelf' widget in use by apps like eog and vinagre. Not sure how to best integrate it, maybe a port to python?

  • In Ubuntu 17.04, I can press my trigger key to escape the guest OS, then press the left alt key, and then type in + search the menu that I can't click on for the "fullscreen" option. This makes it exit fullscreen for me with SPICE. – starbeamrainbowlabs Jul 2 '17 at 14:41
0

If compiz settings include the grid plugin settings, then the white bar doesn't slide down. So what I had to do was use one of the "grid plugin" hotkeys like "<Alt><NumKP3>" to get a smaller window. Then, hovering over the bar allowed me to use the bar to click the button to exit fullscreen.

0

I use Fluxbox window manager when dealing with VMs on my workstation. In order to keep things simple, I run one VM per virtual desktop. Now with a Ctrl+Alt to leave vm focus, and a Ctrl+F1 through F12 I can switch desktops. From here I can close things and reopen things as needed. I don't run Compiz.

0

Shift + F11 work for me I use spicec

0

I just put the mouse in the top centre to of the screen and a toolbar with exit fullscreen appears. Running fedora 23 with gnome

Hope tis helps.

protected by user364819 May 31 '16 at 16:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.