I am using Synapse + Unity Dash for searching and it seems that neither of these can index folders I've accessed in my NTFS partition. I believe this is because Zeitgeist does not index folders, and locate (which Synapse uses, I believe) does not touch my NTFS drive.

So in short, is there any way to index my NTFS partition ? In such a way that it is accessible via locate. Or perhaps make Zeitgeist index folders as well?

As of now, Dash gives results from NTFS partition, but there are no folders in the result. On the other hand, locate gives me folders, but only on the native ubuntu partition.

  • are you still looking for a solution to this? – belacqua Aug 13 '11 at 20:44
  • I've moved to gnome-shell and don't use Dash. But if there is something that adds NTFS indexes to locate, I'm all for it. – Nemo Aug 16 '11 at 17:30
  • @capt-nemo : Is the answer satisfactory? – Manish Sinha Aug 22 '11 at 11:21

Dash is using the index database created by locate. To make locate to index and show file on an NTFS partition, you should edit the file /etc/updatedb.conf, and change the line

PRUNEPATHS="/tmp /var/spool /media"


PRUNEPATHS="/tmp /var/spool"

This works if your NTFS partition is mounted on a mountpoint under /media (highly probable).

To update immediately the locate database, run

sudo updatedb
  • This appears to answer the question, but I'm hoping the OP chimes in. – belacqua Aug 22 '11 at 21:41
  • I'd looked earlier at that conf, but never actually tried changing it. I was wanting something similar to the NTFS solution Everything which uses MFT of the drive, along with the USN journal to maintain its indexes, but I guess I was worried about scanning times being increased. Does locate scan the MFT or build a complete index by scanning directories ? – Nemo Aug 23 '11 at 4:07
  • @Capt.Nemo: I suppose updatedb make a filesystem scanning by directories, and know nothing about the specifics of NTFS or of others filesystems internal. – enzotib Aug 23 '11 at 6:09

Zeitgeist logs events by two ways

  1. Zeitgeist Datahub
  2. Selective Datasources


The first one is installed by default in Ubuntu (Natty and later) along with Zeitgeist. Datahub is a passive logger which is GtkRecentManager on steroids. Any new entry to ~/.recently-used.xbel is taken up by Datahub and added to Zeitgeist

Selective Datasources

Datasources are extensions/plugins/addins/addons for applications which help in logging events. Example Tomboy notes are not logged by datahub as they are not logged by GtkRecentManager.

In this case a Tomboy datasources (implemented as a plugin) can be enabled which logs events like Note Open,Closed, Created and Deleted

If you are on Natty, then you install Datasources for these applications

  • Bzr
  • Emacs
  • Eye of Gnome
  • Geany
  • gedit
  • Rhythmbox
  • Tomboy
  • Totem
  • Vim
  • XChat

You can install the datasources by sudo apt-add-repository ppa:zeitgeist/ppa

and look for packages zeitgeist-datasource-* (e.g. zeitgeist-datasource-rhythmbox)

OTOH you can install Banshee's datasource by installing the package banshee-extensions-zeitgeistdataprovider

If you open files, start/stop tracks, open/close/create/delete notes or any relevant activity from these applications then they will be logged. Even the music tracks are logged(their URI on the disk).

There are be two problems

  • GtkRecentManager fails to work on NTFS partition
  • Everytime you mount your NTFS partition, it is assigned a different mount point. (You can pin it in /etc/fstab)

I can guess the problem can be in latter. Can you try installing banshee datasource, enable the datasource, listen to a few tracks(on NTFS partition) and then try to find them via Synapse or Dash (I personally prefer Synapse)

  • Thanks a lot for the hint about the banshee extension. I've actually pinned the mount point in fstab, and its not that I don't get results from NTFS, its just they are the ones which I've already opened. When I'm searching for something, I'm looking for things that I've not opened before, and that is when Zeiteist fails me. The other solution works in this aspect, so I've marked it as correct. – Nemo Aug 23 '11 at 4:11
  • To solve the problem of Zeitgeist not seeing files, you can install activity-log-manager from this PPA. You can index all the files in your HOME directory using it. – Manish Sinha Aug 23 '11 at 4:27
  • I want to index files "outside" my HOME, and activity-log-manager does not have anything for that. – Nemo Aug 23 '11 at 4:32
  • Where exactly do you want it to index? Which partition? Zeitgeist was aimed for those activities which are related to user's directory to avoid cluttering up the DB with unneeded events – Manish Sinha Aug 23 '11 at 4:40
  • I've got songs outside my home directory on a different partition. Zeitgeist does index them, but only after opening them. I must have misunderstood Zeitgeist earlier. I looked at it as an indexing + search system, while it is more of a user's activity index. Thanks for the clarification. – Nemo Aug 23 '11 at 6:20

Haver you tried Recoll? Is pretty good but so far still having troubles adding the NTFS partitions, everyone tells me that in settings you can do that, but there is no option to add something beside /home

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.