1

this is the first time I ask here. Recently I played packaging --a new thing for me-- in Launchpad.
I tried compiling Sigil 0.7.4 for Ubuntu Precise. The source code had to be compiled with Qt5, while by default Precise only provide Qt4. So I used “Ubuntu SDK team” for the build dependencies.
I did the local building with bzr in Trusty and everything seems to work properly. But the build in the Launchpad stuck with an error. Have a look at the log.

The debian/rules file contains:

#!/usr/bin/make -f
# -*- makefile -*-

include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk

DEB_CMAKE_EXTRA_FLAGS += -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake

According to the build log, the parameter for Cmake extra flags is working. But why it still gave an error? Where is qt5-qmake located, so that it stop giving error?

Thanks in advanced.

Edit
For those who have the same problem, you might have been googling around to solve. I give more details about the error:

   CMake Warning at src/Sigil/CMakeLists.txt:38 (find_package):
  By not providing "FindQt5.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Qt5", but
  CMake did not find one.

  Could not find a package configuration file provided by "Qt5" with any of
  the following names:

    Qt5Config.cmake
    qt5-config.cmake

  Add the installation prefix of "Qt5" to CMAKE_PREFIX_PATH or set "Qt5_DIR"
  to a directory containing one of the above files.  If "Qt5" provides a
  separate development package or SDK, be sure it has been installed.


  CMake Error at src/Sigil/CMakeLists.txt:454 (qt5_wrap_ui):
  Unknown CMake command "qt5_wrap_ui".
  • Did you set that PPA as a build dependency? – saiarcot895 Mar 23 '14 at 23:25
  • Yes, I'vet set Ubuntu SDK Team PPA as my PPA's build dependency. – baddwin Mar 24 '14 at 5:59
  • The error here is not the flag or qmake; the error is that cmake needs to verify that Qt5 is available, so it looks for a file called Qt5Config.cmake or qt5-config.cmake. However, it can't find these files. However, Qt5 does provide cmake files, but you need to spcify the modules you need (see this page for the syntax). – saiarcot895 Mar 24 '14 at 11:51
  • You're right, I might have forgot that this version of Sigil should be compiled by Qt 5.1+, otherwise Ubuntu SDK team only provide Qt 5.0.2. – baddwin Mar 24 '14 at 14:57
  • I was wrong with my last comment. Even after I provided Qt 5.2.1 as build dependency, the build process was still giving the same error. The latest build log. This starts driving me mad, duh! – baddwin Mar 25 '14 at 0:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.