I'm running Ubuntu 12.04 with a Logitech C920 webcam and a brand new Blue Yeti usb mic. My intent was to run through all the input and output devices and settings while plugged in to my laptop, and have a comparison video between my laptop, webcam and usb mic sound quality. The problem, while I have the USB mic plugged in I have no control over input volume, or input device. In sound settings, under "Record sound from" I switch from internal microphone, HD webcam microphone and Yeti stereo microphone. Although the input level meter reflects my tapping on each device as I change them, the actual audio is still only coming from the blue yeti mic. I put the Blue Yeti mic on mute, then select other input choices(such as webcam mic) and I get no input. Also the usb mic is running really hot. I have the gain on the hardware down to 1 as well as input volume on sound settings set to very low, yet the audio is really hot.

In guvcview, I have input as "sysdefault" (there is no yeti option) Changing the input device on guvcview also has no affect on audio quality or actual source. In addition, I have the VU meter showing on my video screen display, and despite the fact that I have the input volume turned way down, the VU meter shows red for peaking. The only way I can get any input from my webcam mic, or laptop is by unplugging the usb mic. The bigger problem is that this usb mic is running really hot and sensitive.

EDIT 1: So I unplugged the usb mic, changed the input in sound settings to "HD pro webcam c920" and changed the input volume slider to "unamplified" and have sysdefault selected as input device on guvcview, yet I still get a very hot signal (If I change input from sysdefault to hd pro webcam in guvcview, I get no audio). So in sound settings, changing the input level slider seems to have no affect on actual input volume. It's very loud and distorted regardless of input level settings. So with both the usb mic and the webcam mic, I am getting no control over input signal, and it's very loud.

Edit 2: I went into PulseAudio with editor:

sudo gedit /etc/pulse/default.pa

And scrolled down to:

load-module module-udev-detect

and added:tsched=0 to the end. So the line will look like:

load-module module-udev-detect tsched=0

Then I clicked save, and I rebooted system. I now have control over volume slider, and input levels. As well as I can now switch devices (laptop mic, yeti mic, webcam mic) while recording video. However, in guvcview, I have to have input selected as "Pulse", not Yeti stereo mic or webcam mic. If I select any other input other than "pulse", I will have no audio.


I was also having issues with my Blue Yeti Pro USB microphone. I figured out how to get it working again. Try using QasHctl to manipulate your device. I have it working now using JACK, pulseaudio, and Bitwig studio. Your mileage may vary. Here's the relevant threads/questions:

Can't select Blue Yeti Pro USB Microphone in sound settings menu


  • This was the only answer that worked for me since the device was already detected and available. I'm a bit baffled by the app you mentioned, but with enough tinkering with settings I got incoming audio levels again. – TenLeftFingers Sep 16 '15 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.