Skype fails to run:

$ skype
skype: error while loading shared libraries: libsqlite3.so.0: cannot open shared object file: No such file or directory

I tried reinstalling Skype (apt-get remove then apt-get install) but it still fails to run.

I tried manually installing the lib:

$ apt-file search libsqlite3.so.0
libsqlite3-0: /usr/lib/x86_64-linux-gnu/libsqlite3.so.0
libsqlite3-0: /usr/lib/x86_64-linux-gnu/libsqlite3.so.0.8.6
libsqlite3-0-dbg: /usr/lib/debug/usr/lib/x86_64-linux-gnu/libsqlite3.so.0.8.6

$ sudo apt-get install libsqlite3-0
libsqlite3-0 is already the newest version.

I tried allowing the 32 bit version:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get -f install skype

I tried uninstalling and reinstalling Skype again. No luck.

I notice that through all the of the above, 'apt-get' never attempted to remove or reinstall the lib. If I try to manually remove the lib, I can't:

$ sudo apt-get remove libsqlite3-0
Some packages could not be installed. This may mean that you have
requested an impossible situation
The following packages have unmet dependencies.
 libatk-wrapper-java : Depends: default-jre but it is not going to be installed or
 libatk-wrapper-java-jni : Depends: default-jre but it is not going to be installed or
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I don't really know what this means, other than it can't be removed because some dependencies will be broken.

Update: As requested:

$ apt-cache policy libsqlite3-0:i386
  Installed: 3.7.17-1ubuntu1
  Candidate: 3.7.17-1ubuntu1
  Version table:
 *** 3.7.17-1ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
        100 /var/lib/dpkg/status

Update 2: as requested:

$ stat /usr/lib/i386-linux-gnu/libsqlite3.so.0
stat: cannot stat ‘/usr/lib/i386-linux-gnu/libsqlite3.so.0’: No such file or directory

I'm on:

  • Ubuntu 13.10 saucy
  • Linux aura 3.11.0-18-generic #32-Ubuntu SMP Tue Feb 18 21:11:14 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
  • CPU is Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz
  • Check apt-cache policy libsqlite3-0:i386. That's the syntax for referring to an i386 library/application. Commented Mar 22, 2014 at 23:31
  • @saiarcot895 output appended to the question. Thanks, but I'm not able to decipher that. I'll go read the man page... Commented Mar 23, 2014 at 0:41
  • That says the latest version of the package has been installed, which is good. Commented Mar 23, 2014 at 0:42
  • Does stat /usr/lib/i386-linux-gnu/libsqlite3.so.0 return something about a symbolic link (basically, anything besides file not found)? Commented Mar 23, 2014 at 0:47
  • 1
    Ok, now run sudo apt-get install --reinstall libsqlite3-0:i386. This will reinstall the package, and shouldn't complain about dependency problems (at any rate, only Skype and i386 libraries might be removed). Commented Mar 23, 2014 at 11:55

1 Answer 1


The problem here is that, for some reason, the libsqlite3 i386 library was missing, even though it was installed as per apt and there are no dependency problems. To fix this, just reinstall the package (sudo apt-get install --reinstall libsqlite3-0:i386).

  • This fixed my problem. Skype now runs fine. Thanks saiarcot895! Commented Mar 23, 2014 at 23:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .