2

I'm trying to install Matlab but I can't open the download_agent installed from mathworks. It's an jnlp file, but if I use open with -> IcedTea in nautilus nothing happens, and when I try

javaws download_agent

or

javaws download_agent.jnlp

I get the message

/usr/bin/javaws: line 66: /usr/lib/jvm/java-6-openjdk-amd64/jre/bin/java: No such 
file or directory

When trying

sudo apt-get install icedtea-netx

It says

icedtea-netx is already the newest version.

I'm running the jdk from Oracle but tried switching to openjdk using

sudo update-alternatives --config java

But it still won't work...always get the message

/usr/bin/javaws: line 66: /usr/lib/jvm/java-6-openjdk-amd64/jre/bin/java: No such 
file or directory

Any suggestions? And many thanks!

  • Btw, in the terminal using ls -l and -al I can't view the file extension .jnlp of the download_agent file...the extension I discovered because nautilus denoted it an .jnlp file, but using file download_agent in the terminal gives me download_agent: XML document text – Kirbies Mar 22 '14 at 21:52
5

This worked for me

# update-alternatives --config javaws
There are 2 choices for the alternative javaws (providing /usr/bin/javaws).

Selection Path Priority Status
------------------------------------------------------------
  0 /usr/lib/jvm/java-6-openjdk-amd64/jre/bin/javaws 1061 auto mode
  1 /usr/lib/jvm/java-6-openjdk-amd64/jre/bin/javaws 1061 manual mode
* 2 /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/javaws 1060 manual mode

Press enter to keep the current choice[*], or type selection number: 2

Unfortunately not my brains, but copied from here https://bugs.launchpad.net/ubuntu/+source/icedtea-web/+bug/969520

| improve this answer | |
0

Wrong path in my case, when I attempt run IcedTea Web control panel (14.04.1) police
Ok, is simple:
1. open sudo nautilus
2. go to /usr/bih/ find itweb-settings
3. right mouse click and opet in gedit itweb-settings

The making first three lines in itweb-settings, like this:

#!/bin/bash
JAVA=/usr/lib/jvm/java-6-openjdk-i386/jre/bin/java
#JAVA=/usr/lib/jvm/java-7-openjdk-i386/jre/bin/java

SAVE it itweb-settings.
Open terminal and execute:
ubuntu@ubuntu:~$ itweb-settings + ENTER
Java control panel show up :-)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.