11

I have a HP Pavilion dv6-2190us Notebook, its got 8GB DDR3 and an i7 processor with 1.60GHz (Turbo Boost up to 2.80GHz)

I'm not sure if I'm doing something wrong or missing step or what but I can't for the life of me figure out how to get the turbo boost working.

It's a real pain because 8x 1.6GHz really sucks, I'm starting to wish I had an i5 with less cores but more clock speed per core...

Is there anything I can do either enable speed step/turbo boost or maybe just keep it overclocked all the time?

Oh, I'm running Ubuntu 10.10 64-bit.

THANKS!

Edit I followed the procure here but my results don't change at all when I execute the loop.

cpu MHz     : 1600.000
cpu MHz     : 1600.000
cpu MHz     : 1600.000
cpu MHz     : 1600.000
cpu MHz     : 1600.000
cpu MHz     : 1600.000
cpu MHz     : 1600.000
cpu MHz     : 1600.000
3
  • Can you please look in /proc/cpuinfo like I wrote in askubuntu.com/questions/37618/is-turbo-boost-working/…, then edit the results into your question?
    – elmicha
    Commented May 19, 2011 at 5:34
  • @elmicha question upadated
    – Alex Weber
    Commented May 19, 2011 at 22:06
  • Try running 'stress -c 8' that will make all your CPU cores run at maximum, while its running check the output of /proc/cpuinfo
    – user270297
    Commented Aug 20, 2014 at 13:39

4 Answers 4

7

Try installing turbostat (from the linux-tools package) and run sudo modprobe msr ; sudo turbostat and see what that says for the processor speed.

The frequency shown in /proc/cpuinfo is always capped to the "normal" CPU speed when in fact turbo boost is working fine.

5
  • 2
    In fact, all the info in /proc/ and /sys/device/system/cpu/ is always limited to regular frequencies by design; see kernel.org/doc/Documentation/cpu-freq/boost.txt
    – Run CMD
    Commented Jul 24, 2014 at 5:53
  • @ClassStacker Thanks! Updated to say "always" instead of "often". Commented Aug 20, 2014 at 13:33
  • @DavidGardner by chance can you explan better how to interpret turbostat output please? In my case Bzy_MHz can go close to 3ghz and then go back to 1ghz after a while, even if all cpus are 100% loaded (see also askubuntu.com/questions/800797/how-to-enable-turbo-boost/…) Commented Jul 20, 2016 at 14:02
  • @SebastienLorber Turbo can be limited by power usage, temperature and other factors, but is quite "closed" in that it won't tell you why :) I'll add some comments on the question you linked to, but at 85 degrees C it could be temperature limiting, depending on the BIOS Turbo settings... Commented Jul 22, 2016 at 18:21
  • That's quite annoying that it's so hard to understand what is happening. I forced fans to run full-speed, tries different governors and drivers, and it seems some time my computer is limiting the frequency to around 800mhz (with load), even if the cpus are not hot Commented Jul 23, 2016 at 9:47
2

Despite not getting any further using any of the solutions, according to i7z turbo boost is, in fact, working.

Not sure what did it, but hey I'm not complaining!

PS - CPU Frequency monitor applet is still stuck at 1.6GHz.

2
  • 2
    I tested the i7z script and it tells me Turbo Boost is enabled. However, using grep MHz /proc/cpuinfo does not show anything beyond the standard clock frequency of 2.3 as opposed to 2.9 GHz.
    – n3rd
    Commented Nov 1, 2011 at 18:07
  • @n3rd All the info in /proc/ and /sys/device/system/cpu/ is always limited to regular frequencies by design; see kernel.org/doc/Documentation/cpu-freq/boost.txt Also, the CPU Freq Mons rely on this information, so they will not show boosts.
    – Run CMD
    Commented Jul 24, 2014 at 5:57
1

Is there anything I can do either enable speed step/turbo boost or maybe just keep it overclocked all the time?

I have got a similar problem with my laptop, I never use ondemand option so I disable it by installing rcconf (sudo apt-get install rcconf). Just open it as root, look for ondemand voice and disable it (space key for select/deselect)!

1
  • 1
    This is a bad advice. First, the OP misinterpreted what he saw. Now you intend to help him addressing a problem that he does not have, not explaining what your assumed solution actually achieves or how it is supposed to fix anything.
    – Run CMD
    Commented Jul 24, 2014 at 6:00
-1

Like sad David Gardner best solution it's turbostat which in additional Linux-tools it show real frequency. It works with cpu on Ivy Bridge where cat /proc/cpuinfo can't show real info. I can also recommend to use this script

cd && wget -O .laptop-mode.sh http://goo.gl/AH0tvj
chmod +x .laptop-mode.sh && ./.laptop-mode.sh

It help tune cpu and force turbo boost to work constantly. I should notice that turbo boost not gonna work with max frequency for all cores. For frequency arrange check official information specs for you cpu.

2
  • 2
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – kiri
    Commented Dec 28, 2013 at 8:14
  • Also the link is an Ubuntu One link which requires login and so doesn't work... Commented Oct 6, 2014 at 13:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .