56

I have Kubuntu 14.04 and just installed the newest updates. Looking at the process list I see baloo indexer running.

I could not find a checkbox in Baloo settings to turn off the indexing.

1
  • I just upgraded to 14.4 and my hard disk is on constantly. Even after adding /home to the list of ignored folders. Obviously, we need to bring back the "disable file indexing" checkbox in the KDE settings. The file indexer has significant negative impact on performance of SSDs and other drives that attempt do do caching in faster flash memory. Even if its "nice" settings prevent it from using too much CPU, if your computer is constantly waiting for i/o, then your CPU is not the bottleneck here. Here is a link to the related bug: bugs.kde.org/show_bug.cgi?id=333433
    – user273109
    Apr 23, 2014 at 15:11

9 Answers 9

24

You can make your file manager display hidden files, after which go to $HOME/.kde/share/config/baloofilerc. It is enough to edit it and change the option

Indexing-Enabled=true 

to (or add if there is not such option)

Indexing-Enabled=false

to disable baloo.

I know it is way too easy but it did work for me and also for the guy who posted this simple solution on this page.

Disabling Akonadi server and Nepomuk search plugin can greatly increase performance in a KDE environment.

4
  • 1
    Also works on Fedora 20 (still on KDE 4.13.3; there is an option 'Enable Desktop Search' in "System Settings > Desktop Search" which precisely updates that option) Jul 26, 2014 at 14:51
  • True for disabling Akonadi can greatly increase performancae in KDE. I tried it and done. Aug 7, 2014 at 4:51
  • 1
    Please note that this option must be under [Basic Settings] section, otherwise it'll not have any effect.
    – Ruslan
    Jan 11, 2016 at 13:41
  • 2
    Running the command balooctl disable will do this for you. Feb 8, 2018 at 23:05
15

Baloo is responsible for desktop search.

Quoting one of the Baloo authors:

There is no explicit “Enable/Disable” button any more. We would like to promote the use of searching and feel that Baloo should never get in the users way. However, we are smart about it and IF you add your HOME directory to the list of “excluded folders”, Baloo will switch itself off since it no longer has anything to index.

enter image description here

8
  • 48
    "There is no explicit “Enable/Disable” button any more. We would like to promote the use of searching and feel that Baloo should never get in the users way". Wow, talk about arrogance. Make it stop using up 100% of my CPU and bringing my computer to a grinding halt and I might think about using it. But this should still be the users' decision.
    – Mike
    Apr 19, 2014 at 1:55
  • 27
    Oh I'll file a bug. The fact that there is no way to disable the bastard without random hackery is a huge fricken bug. Eating 100% cpu and not giving the user a way to turn it off is just bad design. Apr 20, 2014 at 21:40
  • 9
    Completely agree with CountMurphy here. I completely understand the decision to have indexing enabled by default - many users want such a feature - but no option to turn it off ? Uh... by the way, it also eats an entire CPU core on my system.
    – us2012
    Apr 21, 2014 at 15:17
  • 4
    @VangelisTasoulas, that doesn't matter to someone running it on a laptop. The last thing I want to to drain my battery on a feature I don't want enabled. May 7, 2014 at 16:34
  • 5
    Well, disable button is one thing. But the other is that it should be quite obvious that something like this should run under ionice, because that's the real bottleneck here. nice won't change a thing.
    – dhill
    Nov 14, 2014 at 10:57
13

From the Gentoo forum: http://forums.gentoo.org/viewtopic-p-7522240.html

As of KDE 4.13.0 (Kubuntu Trusty) it is no longer possible to disable Semantic Desktop in the GUI. Though there is a "Desktop Search" applet in the System Settings, and you should be able to blacklist your home dir there, doing so has no effect and Baloo (who has taken over from Nepomuk/Strigi) keeps doing its stuff with 100% load and multi-Gigabyte memory use on the CPU core it runs in.

You may check the CPU load on your system using 'top':

top

Check the I/O load on your system with 'iotop':

sudo apt-get install iotop
sudo iotop

To permanently disable baloo, symlink it to /bin/true:

sudo mv /usr/bin/baloo_file_extractor /usr/bin/baloo_file_extractor.orig
sudo ln -s /bin/true /usr/bin/baloo_file_extractor

and

sudo mv /usr/bin/baloo_file_cleaner /usr/bin/baloo_file_cleaner.orig
sudo ln -s /bin/true /usr/bin/baloo_file_cleaner

This will prevent it from ever running again. Doing so will lose search functionality of course, but does not seem to have any adverse effects beyond that.

5
  • 3
    > This will prevent it from ever running again. < Until the next baloo update I guess?
    – warvariuc
    Apr 21, 2014 at 4:06
  • Well, yes ;) I actually like bcmpinc's solution better: renaming the baloo_file.desktop file in /usr/share/autostart/ seems - at least on my system - to suppress it completely, and is less intrusive. Though using the large hammer was certainly more satisfying! :D
    – fman
    Apr 21, 2014 at 15:21
  • I'm not sure if these system files would be reverted in an upgrade.
    – Sparhawk
    May 8, 2014 at 3:26
  • has anyone tried "kwriteconfig --file baloofilerc --group 'Basic Settings' --key 'Indexing-Enabled'" false and then "balooctl disable" and had it actually work? It seems logical that this would stop any and all baloo activity, but it didnt work out that way, i ended doing fman's and bcmpinc's thing which worked great for me... i just decided i hated it so much so i put a hold on the package so i would notice when it was about to be upgraded, if it was needed however i'll have to redo this when i do-release-upgrade the next time. Jul 24, 2014 at 14:24
  • I'd also add chattr +i /usr/bin/baloo_file_cleaner and same for extractor. Then even updates wouldn't change it. Not sure if they will fail or ignore this though.
    – Ruslan
    Jan 11, 2016 at 13:38
10

To avoid manually editing $HOME/.kde/share/config/baloofilerc, this does the same for you:

kwriteconfig --file baloofilerc --group 'Basic Settings' --key 'Indexing-Enabled' false
1
  • The best answer. Because when KDE is too slow to be usable, you can solve this problem from a terminal. Apr 9, 2018 at 15:53
6

I haven't tried it yet, but apparently, you can also do

$ cp /usr/share/autostart/baloo_file.desktop ~/.kde/share/autostart/
$ echo "Hidden=True" >> ~/.kde/share/autostart/baloo_file.desktop

(I had my home folder in the "don't search" section, probably from nepomuk, and baloo_file was still using 100% of a core.)

5
  • 1
    For the others reading this - baloo_file no longer uses 100% of a core. That was a bug that has been fixed for the final release. Apr 8, 2014 at 8:54
  • 5
    No, it is not. I still have this problem. And it fills my RAM (8GB). Can you please provide me a link to the bug, so to reopen it?
    – dadexix86
    Apr 18, 2014 at 16:25
  • @VisheshHanda probably needs to be tagged.
    – Sparhawk
    Apr 18, 2014 at 16:52
  • @dadexix86 Please file a fresh bug. It may not be the same issue. Apr 20, 2014 at 14:41
  • @VisheshHanda after the 3rd of 4th reboot and after removing the previous Nepomuk index it solved itself.
    – dadexix86
    Apr 20, 2014 at 15:00
4

balooctl

As said here and here, just use:

balooctl disable

BTW, config is now on ~/.config/baloofilerc instead of on ~/.kde/share/config/baloofilerc.

2
  • can I delete the baloo ~/.local/share/baloo/index file then? (it is over 1GB on my laptop)
    – rubo77
    May 26, 2019 at 22:26
  • 1
    Seems safe, after a backup :) You could reindex later. May 26, 2019 at 22:48
3

Adding $HOME to the list of excluded paths did stop the baloo_file_extractor, which was using 100% CPU. However it then started baloo_file_cleaner which was trashing my harddisk.

Making sure that it does not autostart, seemed to fix the problems:

sudo mv /usr/share/autostart/baloo_file.desktop /usr/share/autostart/baloo_file.desktop.orig
3
  • I suspect that the system file might be created again (or revert) in a future upgrade. It's probably better to modify the user file instead, as per my answer.
    – Sparhawk
    May 3, 2014 at 5:05
  • Modifying the user file did not work for me. If baloo is re-enabled in a future update, then either the bug is fixed or I'll notice and disable it again. Either is fine.
    – bcmpinc
    Nov 19, 2014 at 11:40
  • Fair enough. Like I said in the answer, I didn't test it. FWIW the 100% CPU bug appears to have disappeared for me.
    – Sparhawk
    Nov 19, 2014 at 12:05
3

Though there are a few ways to prevent Baloo from indexing, my intention is to prevent Baloo from even running. As per The KDE docs there is no User-accessible way to do that, so I've combined a solution found on the KDE forums with user 's solution to disable the executables:

sudo mv /usr/bin/baloo_file /usr/bin/baloo_file-orig
sudo ln -s /bin/true /usr/bin/baloo_file
sudo mv /usr/bin/baloo_file_cleaner /usr/bin/baloo_file_cleaner-orig
sudo ln -s /bin/true /usr/bin/baloo_file_cleaner
sudo mv /usr/bin/baloo_file_extractor /usr/bin/baloo_file_extractor-orig
sudo ln -s /bin/true /usr/bin/baloo_file_extractor

I then go a step further and ensure that baloo cannot be updated, overriding the above symlinks:

$ sudo apt-mark hold  baloo libbaloocore4 libbaloofiles4 libbaloopim4 libbaloowidgets4 libbalooxapian4
$ sudo apt-get remove baloo

For additional insurance, if the baloo process ever does find its way back is to add the following to ~/.kde/share/config/baloofilerc:

[Basic Settings]
Indexing-Enabled=false
1

A post in KDE forums by Aaron Seigo suggests:

qdbus org.kde.baloo.file /indexer suspend

The post is located here: https://forum.kde.org/viewtopic.php?f=154&t=120047#p304335

Use the following to resume:

qdbus org.kde.baloo.file /indexer resume

Use the following to check is baloo is suspended or not:

qdbus org.kde.baloo.file /indexer isSuspended

TIP: When I type qdbus org.kde.baloo.file /indexer and press Tab multiple times in Kubuntu 14.04 with bash-completion enabled (usually enabled by default), I get a list of commands for baloo.

2
  • 1
    The link suggests that this just pauses baloo. Presumably baloo will run again after a restart?
    – Sparhawk
    May 3, 2014 at 5:06
  • Yes, this is true. It stop or pause for the current session. It will not completely turn it off. May 3, 2014 at 8:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.