0

There are already plenty of questions along the same lines, but I don't see them helping: netExtender vpn 6.0 works momentarily then remote hosts timeout -- Already updated but doesn't fix the issue.

How to get Netextender (VPN) working in Ubuntu 12.10 x64? -- not really a solution

How to get NetExtender VPN client on Ubuntu 13.04 working? -- I'm not very sure if I need to go through these steps (please look below)

Disconnecting Netextender VPN: No internet -- not a similar problem.

In my case, netExtender reports connection is successful, here is part of log:

Connected.
Logging in...
Login successful.
failed to retrieve epc agent version
SSL Connection is ready
Using SSL Encryption Cipher 'RC4-SHA'
Using new PPP frame encoding mechanism
Using PPP async mode (chosen by server) 
Connecting tunnel...
Client IP Address: 1.2.3.4 (example)

ifconfig reports:

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:1.2.3.4  P-t-P:192.0.2.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1280  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:590 (590.0 B)  TX bytes:526 (526.0 B)

Even though netEnxtender says connected, I can't access my office VPN.

whatismyip reports my ISP IP after connecting.

I'm using Ubuntu 13.10 (32bit)

[EDIT]: Ok I talked bit too early. Here is actual issue: VPN is connected, I can access all computers with IP addresses but not names, what can be the reason?

  • Update: I turned off computer while VPN was connected and since then VPN is not working – wisemonkey Mar 22 '14 at 21:31
  • You don't need to add Edit to your title. – MrVaykadji Mar 23 '14 at 17:14
1

This is an issue of the DNS server of the network you are connecting to. Does the network you connect to provide a DNS service? Have you asked the network admin? He/she should be able to tell you how to set up your DNS settings to be able to do this.

If you can talk to the admin, well and good. If not, you can set this up for your machine by adding aliases to your /etc/hosts file. Open the file as root and add a line for each of the hosts you want to reach by name:

123.456.7.8  machine1
432.123.45.8 machine42
11.22.33.4   randomsillyname

Save the file and you will be able to connect to IP 11.22.33.4 using the name randomsillyname.

  • Thanks I'll check with IT department tomorrow, if they can't resolve it I'll add proper names to /etc/hosts – wisemonkey Mar 23 '14 at 18:32
  • I've to update my own /etc/hosts cause IT is changing things and don't know what went wrong, thanks for advice :) – wisemonkey Mar 30 '14 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.