7

I own a Thinkpad carbon X1 gen2 notebook with the new touchpad (clickpad). The same clickpad seems to be used in the T440 and W540 models as well. I would like to turn off the touchpad but still be able to use the trackpoint. However, the new clickpad notebooks do not have physical mouse buttons. Instead regions on the touchpad must be mapped to the mouse buttons left, middle, right. I.e. simply turning off the touchpad in the ubuntu/unity settings would disable the mouse buttons as well. In other words, I want the touchpad to work as a button only with three regions corresponding to the traditional mouse buttons (scrolling is not important to me).

There is a lot of info on the web how to configure the touchpad/trackpoint: e.g. thinkwiki or on askubuntu but this information seems to be outdated.

What is the proper (modern) way to make persistent changes to the touchpad/trackpoint configuration in Ubuntu 14.04 (or 13.10)?

I found this solution and tried it with Ubuntu 14.04 alpha:

Section "InputClass"
    Identifier "t440 top buttons"
    MatchDriver "synaptics"
    Option "SoftButtonAreas" "60% 0 0 0 40% 60% 0 0" #Emulate right and midle buttons
    Option "Synaptics Area" "0 0 0 1" #disable moving but not buttons
EndSection

Put the preceding configuration into a file named e.g. 99-carbonx1clickpad.conf and save it in the folder /usr/share/X11/xorg.conf.d/

The effect is that the 3 upper regions of the clickpad are properly mapped but the touchpad movement is not turned off (i.e. the mouse can still be moved around).

Why is the movement still turned on?

Is there some ubuntu specific process that overrides the settings in the xorg.conf.d folder?

Update1:

Some more research revealed the priorities by which the xorg config is read (if this is still up to date). Hence I copied the config file above also to the folder /etc/X11/xorg.conf.d/

Furthermore according to a detailed documentation on the archwiki the gnome settings daemon might override the settings of the xserver hence: uncheck active in /org/gnome/settings-daemon/plugins/mouse/ using the dconf-editor.

However this still does not turn off the touchpad movements... Is there another configuration key for Ubuntu's Unity?

BTW: in future a better solution should be available with synaptics 1.8.

  • You seem to be along the right path. The W530 and T430 still use the separate buttons so I am guessing that if you have outdated information, than the xorg.conf is not correct for the newer touchpad. Try fiddling with some of the options in the xorg. – Mr.Lee Mar 21 '14 at 16:14
  • Also, don't for get to restart lightdm for gnome to apply the new changes. If that doesn't work, a reboot will work. This needs to be done to any modifications for the xorg to take place. – Mr.Lee Mar 21 '14 at 16:20
5

The Option "Synaptics Area" "0 0 0 1" does not work properly. Hence all that is needed is:

Section "InputClass"
    Identifier "tp only with clickpad buttons"
    MatchDriver "synaptics"
    Option "SoftButtonAreas" "60% 0 0 0 40% 60% 0 0" #Emulate right and midle buttons
    Option "AreaBottomEdge" "1" #disable moving but not buttons
EndSection

store this in a file 99-carbonx1clickpad.conf in the folder /usr/share/X11/xorg.conf.d/

tested for ubuntu 13.10 and 14.04 alpha

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.