1

I have a question about the Catalyst drivers and which ones I can actually use with my my distro. I currently have 12.04 and Ubuntu 13.10 installed.

When AMD / ATI tells me that the latest 14.3 Beta driver requires:

  • Xorg/Xserver 7.4 and above (up to 1.15)
  • Linux kernel 2.6 or above (up to 3.13)
  • glibc version 2.2 or 2.3
  • POSIX Shared Memory (/dev/shm) support is required for 3D applications

...does this mean that if I had a distro with all those things but later, newer version, that the driver would still run? Ipso facto, if I wanted to try the 12.10 driver with the latest, or more current software, would it still work since the requirements are below what AMD says is required. For instance, if driver A requires X Server 1.13, and I have 1.15, would the driver work, or would I need that specific X Server?

Is this why people downgrade Xorg?

1 Answer 1

2

I very recently installed that 14.3 beta driver that ATI provides. This was my system specs and I am using Ubuntu 13.10.

  • X.Org/X Server - 1.14.5
  • Kernel 3.11.0
  • Eglibc version - 2.17

So that clearly tells you the story. You dont need to be that specific.

I would suggest that you follow the installer notes and also check the release notes(I suppose you have already) before installing. If anything goes wrong, start a tty session by pressing Ctrl+Alt+F1 then use the command

sudo aticonfig --uninstall

to uninstall the driver you have. Then reboot with,

sudo shutdown -r now

This way you can uninstall the driver if you encounter a problem after installing the driver. But that 14.3 driver seems to be working as far as I know with the specifications that are not too specific as you can clearly see above.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .