64

Only a short question but is it possible to set the default width (and height) of terminal sessions in gnome-terminal and terminator?

I find I always resize the window once it pops up so and given how much I use terminator it makes sense (IMO) to alter the default and save myself some time later on.

8 Answers 8

95

Terminator does allow you setting up a default size. :)

Just open the file ~/.config/terminator/config with your favorite editor. You should have a section titled [layouts]. You only need to add a line within the sub-section named [[[window0]]] belonging to the [[default]] section. My configuration file, for instance, looks like this:

[global_config]
  enabled_plugins = CustomCommandsMenu, InactivityWatch, ActivityWatch, TerminalShot, LaunchpadCodeURLHandler, LaunchpadBugURLHandler
[keybindings]
[profiles]
  [[default]]
    scrollbar_position = hidden
    visible_bell = True
    scrollback_lines = 1000000
    foreground_color = "#ffffff"
    copy_on_selection = True
    background_color = "#300a24"
[layouts]
  [[default]]
    [[[child1]]]
      type = Terminal
      parent = window0
      profile = default
    [[[window0]]]
      type = Window
      parent = ""
      profile = None
      size = 900, 600
[plugins]

The relevant part is only the line starting with "size", of course.

6
  • On Ubuntu 12.04 this file is missing. See here: bugs.launchpad.net/ubuntu/+source/terminator/+bug/1007136
    – Dave
    Jun 11, 2012 at 14:29
  • 5
    The "size" option does not show up in the GUI "Preferences" manager. Also, when I set it in the config file, my window sometimes opens at the correct size, then shrinks itself to some other size. This other size changes inconsistently, and sometimes it stays at the correct size. Any ideas?
    – Eric Dand
    Mar 11, 2015 at 18:19
  • 1
    Also, man terminator_config has no mention of "size".
    – Eric Dand
    Mar 11, 2015 at 18:29
  • 1
    If this file doesn't exist for you then click right in terminator and edit a preference of some kind, then it will automagically create the file for you.
    – Dave
    Oct 6, 2016 at 15:15
  • 2
    This size option is in pixels. Try 1400, 800 to start with and go from there...
    – Dave
    Oct 6, 2016 at 15:18
33

In terminator the GUI option for size is not there. A simple way to set up this is --

First open terminator and set the window size according to your need and comfort.

Right click and go to preference and then to layout.

Click on the terminal name under window and then save the layout.

Thats it, It will open the terminator in the same size, as you have set up, next time you open it.

2
  • Weird gui machanic (nothing seems to update when I click save), but it seems to work, thanks. May 2, 2017 at 10:55
  • @EmileVrijdags power of terminator outplays its bad organization(now, may be in future they will update)....It is worth giving a effort to adjust to it ...enjoy working with it.
    – hunch
    May 4, 2017 at 20:17
8

I don't know about terminator, but in gnome-terminal there's an option under the profile settings to set the starting dimensions to any number of rows and columns you want, specifically Edit->Profile Preferences.

2
  • I don't find this option anymore under Edit -> Profile Preferences. I remember I have set this option before somehow and I even find a gconf entry for this but I can't find a way to set this which works. Any ideas ?
    – koushik
    Oct 10, 2010 at 15:26
  • Hm...you're right. It has vanished from the GUI for some reason. Surely this is all being stored in a config file somewhere... Oct 12, 2010 at 16:07
7

Hey. Assuming that you're calling up terminal from a panel menu or launcher icon, you can just change the instructions in that launcher to included desired geometry.

For example, I have a launcher for gnome-terminal on my gnome-panel which opens up to 80x40. Right click -> properties: command - set to "gnome-terminal (or terminator, whatever) --geometry=80x40"

Useful?

2
  • This is a good answer, except when using a keyboard shortcut to launch a terminal. In that case, see the answer by Ben Willams. Jun 19, 2013 at 9:35
  • I can confirm that this works for terminator. Apr 2, 2017 at 13:32
2

try this for gnome-terminal:

go to edit >> profile preferences

look down:

default size: 80 (you want to increase this)
colums: 24: (you want to increase this too!)

sorry if that are not the "right labels", i'm using ubuntu in spanish

2

Example: gnome-terminal --geometry=80x40+100+200

To make it always keep that setting:

sudo -H gedit /usr/share/vte/termcap/xterm 

Locate something simliar to:

:co#80:it#8:li#24:\

co is column number and li is row number. Adjust as you like.

Thanks to https://superuser.com/questions/226167/open-terminal-on-start-in-a-specific-place-and-size

1

This has disappeared in the latest version of gnome-terminal, 2.30.2-0ubuntu1. My installation of 10.04 LTS picked up the new gnome-terminal package yesterday, and it no longer obeys the geometry settings in the profile.

The fields for setting the default size have disappeared from the options dialog. The option remains set in gconf, however (at /apps/gnome-terminal/profiles/Default/default_size_columns and default_size_rows).

There's a bug report here:

https://bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/647156

0

Accepted answer shows how to launch terminus in a specific size.

If you want to launch it fullscreen or maximized the following option is simpler.

[global_config]
  window_state = maximise
  window_state = fullscreen

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.