1

I bought a laptop 2 weeks ago, wiped Windows8 off and installed Ubuntu 12.04. I've been trying to install synaptiks for the past 6 days trying multiple fix's, so I could configure my touchpad because the touchpad hits my left palm when I type and consistently erases most things because of it and I cant 2 finger vert scroll.

I believed the problem was related to my touchpad driver but I had the its-saucy synaptics installed for everything. When I use xlist it shows my touchpad is identified yet when I run synaptiks it says it can't find a touchpad. Any help greatly appreciated.

The internal error I have is: ExecutablePath: usr/bin/synaptiks

Package: kde-config-touchpad 0.8.1-1ubuntu1.2

ProblemType: Crash

Title: synaptiks crashed with AttributeError in show_configuration_dialog():'SynaptiksNotifierItem'object has no attribute 'touchpad'

Traceback: File"usr/lib/python2,7/dist-packages/synaptiks/kde/trayapplication.py",line 260, in newInstance self.icon.show_configuration_dialog()

File"usr/lib/python2.7/dist-packages/synaptiks/kde/trayapplication.py",line 241, in show_configuration_dialogself.touchpad, self.touchpad_manager,self_config)

Attribute error:'SynaptiksNotifierItem' object has no attribute 'touchpad'

ApportVersion: 2.0.1-0ubuntu17.6

Architecture: amd64

distro: Ubuntu 12.04

if there's any directory spelling mistakes it's because I typed it all out

0

1.Enabling two finger scroll:

Go to Mouse and Touchpad in System Settings. There you can find Two Finger Scroll under Touchpad tab. I hope this solves your problem.

2.Enable/disable Touchpad

This is not an exact solution. But it might solve the issue. You can write a bash script to toggle the touchpad on/off. And give a keyboard shortcut for this script to run.

  • Step 1:

    Open terminal. (press ctrl+alt+t)

  • Step 2:

    Type gedit touchpad and press enter.

  • Step 3:

    Copy the following script.

    SYNSTATE=$(xinput list-props "XXX" | grep Enabled | grep -Eo '.$') if [ $SYNSTATE = 0 ]; then xinput set-prop "XXX" "Device Enabled" 1 else xinput set-prop "XXX" "Device Enabled" 0; fi

    Replace XXX with the name of the touchpad.

    To find out the name of the touchpad just execute command "xinput list" in the terminal.

    Save the document.

  • Step 4:

    Now execute the following commands one by one.

    chmod +x touchpad

    sudo mv touchpad /bin/

  • Step 5:

    Done!!! You can now enable/disable the touchpad just by executing "touchpad" command in the terminal.

  • Step 6:

    To add keyboard shortcut for enabling and disabling touchpad, open Keyboard in System Settings. Under Shortcuts tab, select Custom Shortcuts and add command "touchpad" to the list. Assign a keyboard shortcut to it.

  • 1
    in my mouse controls it doesn't have a touchpad tab – user260350 Mar 21 '14 at 4:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.