0

When I turn on my computer I have the choice of Windows 7 and Ubuntu. I click Ubuntu and it shows wubildr is missing error:oxcoooooof. To fix that error I run bcdedit in a Windows cmd-prompt, but it returns the following: The boot configuration data store could not be opened. Access is denied. What should I do?

1
  • Have you tried running boot-repair from a live usb/cd? – bleeves Mar 20 '14 at 15:58
0

It looks like you installed Ubuntu inside Windows with Wubi. If that is the case you can use this solution which worked for me too. The easiest way to fix Ubuntu is to:

Keep your Windows untouched, as it is, no need to make any change in Windows. As for your Ubuntu, you have to move first both the root.disk and the swap.disk files which are located in folder ubuntu/disks where you previously installed Ubuntu with Wubi. Move root.disk and the swap.disk into some temporary directory, and after that uninstall ubuntu from Control Panel like you do when you have to uninstall any other windows software.

Next step is to reinstall the same release of Ubuntu with Wubi again (you can allocate less disk space than before, it does not matter because you'll be replacing the new root.disk with the old root.disk anyway). Use the same username and the same password as before. Wait until Wubi installer asks you whether you want to 'Reboot now' or 'Reboot Later', and choose to reboot later, do not reboot the computer.

Next, before rebooting to complete the installation of Ubuntu, copy back the old root.disk and swap.disk files that you saved in a temporary folder and override the new ones present in folder ubuntu/disks where your new ubuntu installation is. After that you can reboot, and Ubuntu should boot as before preserving all your system settings and packages.

After you login into Ubuntu, open a terminal and run this command in the terminal:

 sudo update-grub

And I think that is all. The only thing you should not do for this to work is to install a different version of Ubuntu. Nothing will work if you do that.

2
  • The root.disk and swap.disk are not in my computer I searched ubuntu/disks – user241104 Mar 29 '14 at 21:53
  • Maybe you uninstalled Ubuntu or you just deleted the disks in a hurry. You should uninstall Ubuntu from Control Panel - Programs and Features and after that do a fresh install. I can't think of no other way since you lost your old virtual disks, both root and swap. But if you perform a fresh install, try to install Ubuntu on a separate partition and not where Win7 is. Also, you should not allocate more than 30GB if you install Ubuntu inside Windows with wubi. 30GB is the maximum size for a wubi based installation. – Taz D. Mar 29 '14 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.