4

I'm using Ubuntu 12.04 for almost a week now and tried Deluge 1.3.6 (through the ppa their website provided), but it keeps crashing. I don't really know why it does though. I had searched the internet for more information on it, but couldn't find the reason nor a solution. I tried deluge 1.3.5 without the ppa, which crashed also.

I noticed that the versions of libtorrent differ when asking deluge or the package manager.

user@pc:~$ deluge -v
deluge: 1.3.6
libtorrent: 0.15.10.0

While it says 0.15.10-1 in the package manager after libtorrent-rasterbar6. Not sure if this is related to the problem though.

Since the crash report is quite large, I didn't really know what information to provide, but I read deluge was supposedly be a good torrent client for Ubuntu, so what do you think the problem is and what can I do to fix this?

@Rinzwind: The warning is when starting Deluge, the segmentation fault is when it crashes.

/usr/lib/python2.7/dist-packages/deluge/ui/gtkui/mainwindow.py:108: Warning: g_object_unref: assertion `G_IS_OBJECT (object)' failed
  gtk.main_iteration(False)
Segmentation fault (core dumped)

Update After updating to 0.16.14.0 as mentioned in Cas's answer, the warning remains, though it hasn't crashed yet. I'll update if it crashes again.

  • Start it from command line and post the error messages. – Rinzwind Mar 20 '14 at 13:55
  • @Rinzwind Error messages added. – Peter Raeves Mar 21 '14 at 15:51
  • FYI: Any GTK warnings are irrelevant to the crash and can be ignored. – Cas Jul 20 '14 at 11:33
8

There is a known libcrypto issue with 0.15 libtorrent on 12.04 so you can use 0.16 libtorrent from the Deluge PPA

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.