I use Ubuntu 12.04 and XFCE desktop on a PC with nVidia graphics card. I ran into Segmentation fault during a Ubuntu update process. An very inconvenient consequence is that .png files cannot be recognized any more thus many programs cannot be started (e.g. gnome-commander, stardict). Also many icons are missing, as well as the min/max/close button icons. I tried open .png using eog and got "unrecognized image file format". I tried reinstall libgdk-pixbuf2.0-0 and librsvg and always got segmentation fault.

Setting up libgdk-pixbuf2.0-0 (2.26.1-1) ... 
Segmentation fault (core dumped) 
Setting up libgdk-pixbuf2.0-0:i386 (2.26.1-1) ...
Processing triggers for libc-bin ... 
ldconfig deferred processing now taking place

running gdk-pixbuf-query-loaders brings up segfaults as well (but not gdk-pixbuf-pixdata or gdk-pixbuf-csource):

>gdk-pixbuf-query-loaders --update-cache
Segmentation fault (core dumped)

I tried logging into gnome and saw the same effect. I tried downloading libgdk-pixbuf2.0-0 package file .deb and installing from command line and got segfaults, too. Any suggestions on how to fix it?

Update: I carefully checked all the dependencies' versions in the precise-update database and none of them have problems.


After a lot of Googling and Binging I finally found a solution for me. I'm running BackBox 4.4 which is based on Ubuntu 14.04 LTS on an x86_64 machine but I had this same problem where xfce starts and works normally but images, the menus and icons were not loading. So my desktop background was blank and most icons were missing in the menu. However I remember having this same error during an "apt-get upgrade" as mentioned above. In short here was my fix:

sudo dpkg-reconfigure libgdk-pixbuf-2.0-0
sudo dpkg-reconfigure libglib-2.0-0

Then logout and log in and voila! (no restart required).

Thanks for pointing me in the right direction. Other posts out there have not looked into that.

| improve this answer | |

Since my yesterday post, I cannot comment on your other question, but here is my answer on launchpad :

Yeah I have recovered my laptop ! (well an expert of my company did so)

I don't know how this is related but here are his steps :

  • removed a ppa that I previously added (/etc/apt/sources.list.d/webupd8team-gvfs-libmtp-precise.list)
  • reinstalled a few corresponding packages (gvfs, libglib2.0-0)
  • reconfigure libgdk-pixbuf2.0-0

It seems libglib2.0-0 was causing the problem. I don't know if this will be okay for most people, but it should help at least debug :-)

| improve this answer | |
  • this did not help me. I removed the ppa and force reinstalled gvfs* and libglib2.0-0*. I still got segfault when reinstall libgdk-pixbuf2.0-0 and run gdk-pixbuf-queryloaders – HongboZhu Mar 21 '14 at 13:14
  • which version have you now ? – shavounet Mar 21 '14 at 13:17
  • Ubuntu 12.04.4 LTS – HongboZhu Mar 21 '14 at 13:18
  • * for glib :) mine is 2.32.4-0ubuntu1 – shavounet Mar 21 '14 at 13:21
  • Setting up libglib2.0-0 (2.32.4-0ubuntu1) ... Setting up libglib2.0-0:i386 (2.32.4-0ubuntu1) ... – HongboZhu Mar 21 '14 at 13:30

Remove the ppa: sudo rm /etc/apt/sources.list.d/webupd8team-gvfs-libmtp-precise.list

Then: sudo apt-get update

After that force uninstall of the libglib library with:

sudo dpkg -P --force-all --force-remove-reinstreq libglib2.0-0

You can then reinstall it from the regular ubuntu ppas: sudo apt-get install libglib2.0-0

Finally you need to downgrade glib-networking-common and gvfs-common:

sudo apt-get install glib-networking-common=2.32.1-1ubuntu2
sudo apt-get install gvfs-common=1.12.1-0ubuntu1.2ppa8~precise3

Libraries version should be:

libglib2.0-0: 2.32.4-0ubuntu

gvfs-common: 1.12.1-0ubuntu

libgdk-pixbuf2: 2.26.1-1

But apparently you already have all the correct library versions, that is really weird..

| improve this answer | |
  • I do not have that webupd8team ppa. I had only a java ppa from them and I have purged them. All library versions are carefully compared to the official DB. – HongboZhu Mar 24 '14 at 8:21
  • In your final step, why not the official gvfs-common version? (packages.ubuntu.com/precise-updates/libs/gvfs) – HongboZhu Mar 24 '14 at 8:27
  • I remember apt telling me gvfs-common: 1.12.1-0ubuntu was the correct version for libglib2.0-0: 2.32.4-0ubuntu – fkoessler Mar 24 '14 at 8:43
  • but you installed gvfs-common=1.12.1-0ubuntu1.2ppa8~precise3? – HongboZhu Mar 24 '14 at 9:07
  • I'm pretty sure those are the commands I used to downgrade the libraries. Quite weird because it doesn't match the versions I have installed (checked with dpkg -l and listed at bottom of answer). In any case, those are the versions you want to have because after that pixbuf doesn't segfault anymore – fkoessler Mar 24 '14 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.