4

I have installed Sketchup on my computer with with WineTricks, however this time I get the following error message when I start sketchup (after the intro window):

Sketchup was unable to initialize Open GL

I googled the error and found out that to solve, as winehq puts it:

If you get the error "SketchUp was unable to initialize OpenGL!", run regedit, open HKEY_CURRENT_USER\Software\Google\SketchUp6\GLConfig\Display, and change HW_OK to 1. "

However this doesn't work because what I get is this when I open regedit, I cannot apply any changes because there isn't even a google folder to open!

It is not a hardware error because I have installed Sketchup before on this computer with the same operating system (I had to reinstall Ubuntu) and I didn't have that many issues. I have tried Installing sketchup from the main website as I had done previously but it is not working now.

Thank you.

1
  • You can create the Google folder by right-clicking on Software and adding a new key. Mar 19 '14 at 23:46
5

I had this problem too: You can find the key by doing this:

  • In the dash, type 'wine' and amongst others it shows the icon for the winetricks program.
  • If you start that, you can then choose 'sketchup' in the boxes, and choose to run 'regedit' thereafter...
  • Once I did that I could find the key as mentioned above, and change it to a '1'.
  • Close it, restart sketchup, and TADA! it works :)
0

I had the same problem-- no Google folder when running the regedit.exe found in wine "drive:c". Then I found another regedit in a winetricks submenu, and there it was. I applied winehq's OpenGL fix described by Christian above. This was a Sketchup 8 installation in Mint 17. Works fine now.

2
  • 1
    can you add more detail?
    – Panther
    Apr 17 '15 at 11:56
  • 1
    In particular, the precise registry key(s) and the nature of the OpenGL fix would be of interest. Apr 17 '15 at 13:36
0

I don't really know what I am doing BUT . . .

  1. Open the file broszer
  2. Look for the 'playonlinuxes virtual drives' in my user root directory.
  3. Clicked the triangle to show the contents
  4. Saw googlesketchup8
  5. Clicked the triangle to show the contents
  6. Opened user.reg with the text editor
  7. Search for "HW_OK"
  8. Change the last 0 to a 1
  9. Save and exit
  10. this time - no opengl error.

Not the answer you're looking for? Browse other questions tagged or ask your own question.