I can't install Ubuntu on my new ASUS R510D laptop. I have messed with it for days. My laptop model is R510D. Its an AMD A10 Elite Quad Core. It has a Radeon HD 8670M 2GB card built in. Its running windows 8.1 64 bit and I want to run Ubuntu 64 bit along side of it. I have updated all of my video drivers and updated all of my windows drivers, i have also updated my bios to the latest version (Version 2.15.1227).

I have shrunk my disk to have unallocated space to install Ubuntu. I made a bootable USB of Ubuntu 13.10 and have set the UEFI bios to FAST BOOT = Disabled, SECURE BOOT = Disabled. I have selected the boot device to be the bootable USB and it loads the GNU GRUB version 1.99 main screen which says "Try Ubuntu without installing" "Install Ubuntu" and "Check disc for defects."

If I try to run or install it will just go to a black screen and do nothing more. If I press cntl+alt+dlt it will go back to the GNU GRUB menu. I can press e and edit the GRUB, so I have tried to add the line NOMODESET before quite splash to no avail. I have changed Quite splash to No splash and I see nothing. I have put NOMODESET after quite splash and even replaced quite splash with NOMODESET. I went back to the bios and tried to run it in Legacy mode by enabling LAUNCH CSM and LAUNCH PXE OpROM. This did nothing to rectify this issue either.

Nothing is working. Does anyone have any idea of what I need to do to install Ubuntu?

P.S. I thought the USB could be the issue so I downloaded the disk image again, even tried downloading 12.04 and it still hangs on the black screen. So if you're thinking my files or disk is corrupt, thats not it either.

  • Does the liveCD work? – Mr.Lee Mar 19 '14 at 21:16
  • I havent tried liveCD... Is liveCD just burning iso to DVD? – Dackenshire Mar 19 '14 at 22:12
  • The liveCD is a DVD or USB that has the liveCD iso. It is usually the same iso as the installation itself. When installing Ubuntu, it is the "Try Ubuntu" option. – Mr.Lee Mar 19 '14 at 23:02
  • So I tried just burning a DVD with the iso, after putting it in Legacy mode and pressing esc I was able to boot from DVD. It installed Ubuntu finally. But now that it restarted, everytime I start it the screen flashes white and asks me if I want to enter low graphics mode. If I select to enter it, it goes to a black screen with command prompt underscore. All I can do is restart the computer, it will not let me start Ubuntu beyond this point. – Dackenshire Mar 19 '14 at 23:45
  • Does the "Try Ubuntu" work? This sounds like a graphics issue. In your BIOS, check to see if you can change your graphics card to discrete or disabled. I think it would be at some hybrid mode at the moment which doesn't work well with ubuntu. – Mr.Lee Mar 19 '14 at 23:48

You have a graphics card issue. More specifically the "Radeon HD 8670M" is your culprit. Hybrid graphics cards for mobile have not played well with Ubuntu in the past. Luckily, many people have this issue. Here is one fix in this thread. If it doesn't work out for you, just google "Radeon HD 8670M ubuntu" or anything of the source and you will find tons of information.

Here is a launchpad thread with similar issue

This is a very generic solution

Good luck! My only wish is that everything worked out of box.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.