1

I am using Ubuntu 14.04 on my laptop and my fan is not working(with Ubuntu 12.04 and Ubuntu 13.10 it was the same).

Short summary of my system

Quanta TWH motherboard, Intel® Core™ i7-2630QM CPU

I follow 3 different ways to solve my problem

1. Using lm-sensors, pwmconfig and fancontrol to control the speed of my fan

First, I try to see what was happening with lm-sensors, I even could not detect my fan. Later on, forced with modeprobe Ref1 with following command line.

sudo modprobe w83627ehf-isa-fff8

It helps to get more sensors with lm-sensors-detect but they all in ALARM, I believe they are set as null because I create them artificially or not(I am not sure about what is modeprobe is doing for me)?

Here is my sudo sensors results after that process.

acpitz-virtual-0
Adapter: Virtual device
temp1:        +61.0 C  (crit = +101.0 C)

w83627ehf-isa-fff8
Adapter: ISA adapter
Vcore:        +2.04 V  (min =  +2.04 V, max =  +2.04 V)  ALARM
in1:          +2.04 V  (min =  +2.04 V, max =  +2.04 V)  ALARM
AVCC:         +4.08 V  (min =  +4.08 V, max =  +4.08 V)  ALARM
+3.3V:        +4.08 V  (min =  +4.08 V, max =  +4.08 V)  ALARM
in4:          +2.04 V  (min =  +2.04 V, max =  +2.04 V)  ALARM
in5:          +2.04 V  (min =  +2.04 V, max =  +2.04 V)  ALARM
in6:          +2.04 V  (min =  +2.04 V, max =  +2.04 V)  ALARM
3VSB:         +4.08 V  (min =  +4.08 V, max =  +4.08 V)  ALARM
Vbat:         +4.08 V  (min =  +4.08 V, max =  +4.08 V)  ALARM
in9:          +2.04 V  (min =  +2.04 V, max =  +2.04 V)  ALARM
fan1:           0 RPM  (min =    0 RPM, div = 128)  ALARM
fan2:           0 RPM  (min =    0 RPM, div = 128)  ALARM
fan3:           0 RPM  (min =    0 RPM, div = 128)  ALARM
temp1:         -1.0 C  (high =  -1.0 C, hyst =  -1.0 C)  ALARM  sensor = CPU diode
temp2:         +0.0 C  (high =  +0.0 C, hyst =  +0.0 C)  ALARM  sensor = CPU diode
temp3:         +0.0 C  (high =  +0.0 C, hyst =  +0.0 C)  ALARM  sensor = CPU diode
cpu0_vid:    +1.219 V
intrusion0:  ALARM

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +61.0 C  (high = +86.0 C, crit = +100.0 C)
Core 0:         +57.0 C  (high = +86.0 C, crit = +100.0 C)
Core 1:         +61.0 C  (high = +86.0 C, crit = +100.0 C)
Core 2:         +57.0 C  (high = +86.0 C, crit = +100.0 C)
Core 3:         +57.0 C  (high = +86.0 C, crit = +100.0 C)

pkg-temp-0-virtual-0
Adapter: Virtual device
temp1:        +61.0 C  

At that point, I try to run sudo pwmconfig. Still, I am not able go further from There are no usable PWM outputs. I stack here with this way. (My computer is not Dell)

2. Install the latest microcode for my processor

I instal the following the steps given here, thanks to @floppy for the advise.

Installing intel-microcode and microcode.ctl packages (as @floppy suggested) are help to wake up my fan, it helps to decrease CPU temperature. Fan was working quite independent from CPU temperature. It was doing some work but still not efficient at all.

Furthermore, sensors-detect is still not able to get my fan without that sudo modprobe w83627ehf-isa-fff8

3. BIOS Update

Okey my CPU temperature is lower, but still not enough to perform even for the basic applications.

I also think about to update my BIOS, but I could not convince myself it might be the reason of my problem in the beginning. I have QUANTA TWH motherbord with i7-2630qm with INSYDE QR133 BIOS. I update it with USB up-to the QR192.

BIOS update decreases my CPU temperatures around 10~15 Celcius, I do not know how and why.

I am still looking for alternative methods to control my fan, or/and force it to work at given/at the maximum rate all the time

  • What are you asking? If the fan is broke, then fix it. – psusi Mar 19 '14 at 19:19
  • My fan is working, I have the dual boot and in Windows everything is OK. – trblnc Mar 19 '14 at 19:31
  • Then what are you asking? Why you can't read the speed in Linux? – psusi Mar 19 '14 at 19:52
  • Sorry may be this confusion because of my bad selection on words, fan was working physically but was not responding any CPU temperature under Linux control(0 rpm). Thanks to the @floppy's advise fan is alive now but it is still not detected by lm-sensors. – trblnc Mar 19 '14 at 20:05
2

Try installing the latest microcode for your processor. According to some linux gurus you may be able to improve the functioning of the central processor (CPU) in your computer by applying the latest Intel or AMD microcode. This will improve the functioning of your CPU, because it corrects bugs in the default microcode that it receives from the motherboard.

Visit this page to learn how to install the microcode package for your CPU. Basically, you have to open Synaptic, and search for intel-microcode and microcode.ctl packages. I hope I am not wrong, and your CPU is from Intel. Amd CPUs can also benefit from this microcode package but it has a different name, amd64-microcode.

Maybe after you install intel microcode, and restart you computer your fan will come to live again.

  • I install it, my fan is alive again but still lm-sensors not able to detect pwm utilities. Thanks a lot for the help. – trblnc Mar 19 '14 at 20:00
  • Wow, it really worked. I can't say I am not a little bit surprised. I have a Dell Optiplex machine, older generation, and I don't think intel microcode makes a lot of difference for my computer but from what I've read about this microcode package is that it is mostly targeted for newest computers, desktops and laptops alike, with latest CPUs and so on. Don't forget to check my answer as the one you accepted so i can get the 'gold' they give you in here for each useful answer. – Taz D. Mar 19 '14 at 20:23
  • Yes, it is nice but still I am not able to detect my fan with sensors-detect, and so there is no pwm control chance. – trblnc Mar 19 '14 at 20:27
  • Can this link be of any help: askubuntu.com/questions/22108/how-to-control-fan-speed You should not limit your search for a solution to Ubuntu forums only, try a wider search, I mean use 'Linux sensors-detect' for a search. And you should also go to your manufacturer page to see if they have support for Linux, and maybe download some of their tools. – Taz D. Mar 19 '14 at 20:35
  • Look, another useful link, I hope, it also says something about installing a graphical interface for checking up on our hardware sudo apt-get install sensors-applet . This is the link: techthrob.com/2009/03/enabling-hardware-sensors-in-linux – Taz D. Mar 19 '14 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.