2

I've installed TFTP to the best of my knowlege, and am trying to perform a basic function test of

     get uImage

when run in normal user, I get permission denied, when using sudo it replies back

    Transfer timed out.

with verbose mode on, it gives me

    getting from localhost:uImage to uImage [netascii]
    Transfer timed out.

I have no idea what's gone wrong.

2

Try on this way. Work for me.

Install following packages.

sudo apt-get install xinetd tftpd tftp

Create /etc/xinetd.d/tftp

and put this entry

service tftp
{
protocol        = udp
port            = 69
socket_type     = dgram
wait            = yes
user            = nobody
server          = /usr/sbin/in.tftpd
server_args     = /tftpboot
disable         = no
}

Create a folder /tftpboot this should match whatever you gave in server_args. mostly it will be tftpboot

sudo mkdir /tftpboot
sudo chmod -R 777 /tftpboot
sudo chown -R nobody /tftpboot

Restart the xinetd service.

sudo /etc/init.d/xinetd restart
  • done all, till I got command not found after trying the restart. xinetd does exist, however its simply not restarting. ls -l gave me Lrwxrwxrwx 1 root root 21 Dec 6 2010 xinetd -> /lib/init/upstart-job – Velocity Drift Mar 19 '14 at 15:16
  • First command install xinetd. Please check again. I running tftp server on my pc configured on this way, – 2707974 Mar 19 '14 at 19:48
  • purged and reinstalled, before trying sudo service xinetd restart...Worked like a treat, rtfp also worked after that. Apologies for not thinking to use service. – Velocity Drift Mar 20 '14 at 8:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.