4

If you are also affected, upvote the question so it causes more attention.

My system is ubuntu 12.04 on Linux 3.8.0-37-generic. I got some crash report after a system update today (seemly from librsvg2-common). After I reboot the PC, I notice some of the icons are missing. In addition, I cannot open some image files formats like .png files. After some googling I tried to re-install librsvg-related packages. But I constantly got Segmentation fault

Unpacking librsvg2-common (from .../librsvg2-common_2.36.1-0ubuntu1.1_amd64.deb) ... 
Processing triggers for libgdk-pixbuf2.0-0 ... 
Segmentation fault (core dumped)
Setting up librsvg2-common (2.36.1-0ubuntu1.1) ... 
Processing triggers for libgdk-pixbuf2.0-0 ... 
Segmentation fault (core dumped)

I also tried to force reinstall libgdk-pixbuf2.0 related package but got segmentation fault, too.

I also tried:

sudo rm /var/cache/apt/*.bin

and

sudo apt-get install -f

but it did not help. I downloaded the .deb package and tried installing it but same segfault msg.

How could I possibly have libgdk-pixbuf2.0 and librsvg2-common packages installed? Or can I roll back to the point before the system update?

Update: I carefully checked all the dependencies' versions in the precise-update database and none of them have problems.

11
  • 1
    see my other question for the consequence of this segfaults issue: askubuntu.com/questions/436791/… – HongboZhu Mar 20 '14 at 10:18
  • after editing /var/lib/dpkg/triggers/File, the force re-installation of libgdk-pixbuf2.0-0 still gives segfault (core dump) :-( – HongboZhu Mar 20 '14 at 14:36
  • But after the unsuccessful force re-installation, I notice four new lines added to the /var/lib/dpkg/triggers/File: /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders libgdk-pixbuf2.0-0 /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders libgdk-pixbuf2.0-0 /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders libgdk-pixbuf2.0-0:i386 /usr/lib/i386-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders libgdk-pixbuf2.0-0:i386. Three folds are mentioned. But I do not have the fold /usr/lib/gdk-pixbuf-2.0 on my system. I have only the other two. – HongboZhu Mar 20 '14 at 14:51
  • @Sneetsher, I do not get it. What is this new suggestion different from the previous? – HongboZhu Mar 20 '14 at 15:24
  • 2
    Unable to comment... Launchpad bug: bugs.launchpad.net/ubuntu/+source/gdk-pixbuf/+bug/1174253 Please add your info to the bug – cyberbill79 Mar 20 '14 at 17:23

Browse other questions tagged or ask your own question.