4

Every 20 minutes, for days, sm-msp-queue (something related to sendmail, I guess) writes a message in my ubun that goes like that:

unable to qualify my own domain name (ubun) -- using short name

where ubun is the network node hostname (output of uname -n and contents of /etc/hostname).

The contents of /etc/mail/local-host-names include two lines: localhost and ubun.

The file /etc/hosts begins with two lines:

127.0.0.1 localhost
127.0.0.1 ubun

The file /etc/cron.d/sendmail contains one cronjob that is set to run every 20 minutes:

*/20 *    *    *    *   smmsp test -x /etc/init.d/sendmail && /usr/share/sendmail/sendmail cron-msp

However, I don't know what the command smmsp should do; I can't run it alone, also with sudo (I get sudo: smmsp: command not found). Running sudo /usr/share/sendmail/sendmail cron-msp seems to be doing nothing.

Any ideas?

11

If you have a fully qualified domain name for your server, this message should go away. In /etc/hosts, you can define a FQDN like ubun.somedomain.tld :

127.0.0.1 localhost
127.0.0.1 ubun.example.com ubun

To apply the new host name without rebooting the system type (after having changed the /etc/hosts file) :

$ sudo hostname ubun.example.com

Then check you have the FQDN :

$ hostname -f

smmsp at the place you show it (in /etc/cron.d/sendmail is not the command name but the username to use to run the command that follows. The rest of the line is the command (testing if sendmail is present and executable and then run it with a specific option for executing actions to do in crontab).

If run at the terminal the command seems to do nothing (print nothing on the screen) this doesn't mean that she doesn't do something.

By the way, this command is run at regular interval to do the submission of mails waiting in the queues of Sendmail. So if you disable it, mails will never be delivered.

2
  • 2
    And what if you don't have an FQDN?
    – Ken Sharp
    Feb 17 '15 at 1:28
  • @KenSharp make one up - it just has to meet FQDN criteria
    – jlb
    Mar 2 '16 at 2:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.