3

I’m on Ubuntu 12.04 running GTK 2.x+ I was experimenting with new terminals and messed up terminology, I tried to do sudo apt-get autoremove terminology thinking that would remove the program and settings, then reinstalled it sudo apt-get install terminology but when I run the program I get the same issues and this output if run via another console.

renamon@Gibson{~}:terminology
ERR<13620>:elementary elm_prefs.c:2139 _elm_prefs_init() prefs iface module could not be loaded, the prefs widget won't function
ERR<13620>:efreet_cache lib/efreet/efreet_cache.c:1108 on_send_register() org.freedesktop.DBus.Error.ServiceUnknown The name org.enlightenment.Efreet was not provided by any .service files
renamon@Gibson{~}:

Any help on this issue? How do I reset terminology prefrences? Can this application even be used in Ubuntu?

1
  • Can you run any other terminals? I would guess that removing terminology's config files will solve this. What's the output of echo .terminolog* ./config/terminology*?
    – terdon
    Mar 19 '14 at 1:47
7

As a general rule, application-specific settings are kept either in hidden dotfiles/dotdirectories in your $HOME or in subdirectories of $HOME/.config. For example, the config file for conky is ~/.conkyrc while the configuration files for the links2 browser are in ~/.links2/ while those for vlc are in ~/.config/vlc.

So, have a look at the hidden files in your $HOME, look for any whose name contains terminology. You can do this with this command:

echo .terminolog* ./config/terminology*

That should list the config files/dirs of terminology and deleting them (or moving them) should get the program back.


Remember that even if you have removed the default terminal, you can still run xterm or always drop to a cirtual console with Ctrl + Alt + F2 (get back to your GUI with Ctrl + ALt+ F7, or F8 depending on your system).

Alternatively, you can list the files in the file browser if you enable "show hidden files".

2
  1. sudo apt-get remove --purge terminology
  2. sudo apt autoremove
  3. find $HOME -name "*erminology*"

    Now you know that config files are here (or?)

    /home/dx/.config/terminology
    
  4. rm -r ~/.config/terminology

  5. sudo apt-get install terminology
  6. Profit!

PS.:

This answer is based on this AskUbuntu answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.