1

I am trying to fly the ardrone parrot 2.0 using tum_ardrone ptam module. It is a rospackage, so I had to make it using

       rosmake tum_ardrone

The above compiled with 0 failures. however, when I do the following commad

       rosrun tum_ardrone drone_stateestimation

I get the following error

      [rosrun] Couldn't find executable named drone_stateestimation below

      /home/bojan/fuerte_workspace/tum_ardrone

I tried to google and get a solid pipelined solution to check for the reason for this error and solve it, but I did not get it. Am new to ubuntu, thus your help is much appreicated. This error doesn't seem to be package specific since the same package works fine in another laptop I tested. Am runnign Ubuntu in vmWare. Does that make any difference?

Thanks in advance

  • 1
    I don't think this is an ubuntu issue at all... I think you need to reinstall ardrone. Regardless "ros != ubuntu". – Elliott Frisch Mar 18 '14 at 19:05
  • @ElliottFrisch : I tried, but its still not working. Every other executable is working. For eg : drone_gui etc. Except this one. Any other specific reason for this? – Lakshmi Narayanan Mar 20 '14 at 4:33
  • Does find /home/bojan/fuerte_workspace/tum_ardrone -name "drone_stateestimation" actually find an executable? – Elliott Frisch Mar 20 '14 at 4:54
  • actually, the executable is not found in the bin folder. it is not created. but in cmake it is there. target executable and is linked with the libraries. wat can be the issue then @ElliottFrisch – Lakshmi Narayanan Mar 20 '14 at 11:11
  • You should probably post that as a question on stackoverflow. It isn't an Ubuntu package, your appear to be having an issue with building your software. You may be able to follow these instructions, but I have never worked with your "AR_drone". – Elliott Frisch Mar 20 '14 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.