10

I've added a VPN using System > Preferences > Network Connections. However, I can't see how to switch it on, because there's no Network Manager icon in the notification area!

nm-applet is running as me; stopping and restarting it doesn't help, nor does logging in and out. It's possible that nm-applet thinks it doesn't need to display an icon because I have wired networking - if so, how do I change its mind?

I'm running Ubuntu 10.04 "lucid" i386. Thanks!

3 Answers 3

7

I fixed it!

The solution was to remove eth0 from /etc/network/interfaces - it ended up there because I installed this system over the network rather than using a CD. I logged out and went to a console window, and did the following:

sudo stop gdm
sudo stop network-manager
sudo ifdown eth0
sudoedit /etc/network/interfaces # comment out eth0 entry
sudo start network-manager
sudo start gdm

I then logged back in, and the icon was present! Rar!

3
  • nice that you shared your answer +1
    – eddy147
    Sep 19, 2010 at 17:13
  • This makes sense, network-manager ignores interfaces put in /etc/network/interfaces Sep 19, 2010 at 17:21
  • Banzai! This problem was a true pain in the ass, preventing me from using command line installs from alternate CD, my sincerest thanks! If I do that before activating GUI in minimal installs, will the icon show?
    – Oxwivi
    Feb 17, 2011 at 19:26
1

Go to panel preferences and edit Notification area, check that icon size =16px as below the nm-applet icon vanishes!

update to xfce 4.10 fixes it I think.

upgrade xfce 4.10

seems there are multiple reasons for this problem!

0

Some things you could try:

  1. Adding a Notification Area applet to the panel (in case, for some reason, the notification area has been removed).

  2. Restarting the panel. Some times I find that icons don't display properly but killing the gnome panel fixes this. Press Alt-F2 and enter xkill (your cursor should change to an X shape) and click on the panel.

The icon should always display, even if you are disconnected or connected to a wired network.

1
  • Thanks - sadly, no joy! I tried removing and re-adding the Notification Area as well as xkill'ing the panel - the Notification Panel remains empty, though I can right-click on the three horizontal lines for the "About" dialog and see "Notification Area 2.30.2". Sep 19, 2010 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.