31

I've connected a HDTV with HDMI on my Radeon 4670, using the open source ati driver. However there is "overscan" which cuts off a bit of each edge of the screen, about the size of the gnome-panel. How can I fix this so it displays the full resolution?

  • Is there a more current solution for 14.04? I'm still having this problem in 2015. DDG took me here – semitones Feb 25 '15 at 20:39
  • 1
    @semitones it's not Ubuntu, it's the TV. – TheWanderer Nov 14 '15 at 22:38

12 Answers 12

42

The issue was with the TV, not Ubuntu.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • For the Sharp Aquos, it's under Menu > System Options > View Option > View Mode > Dot by Dot – Pakman Aug 30 '12 at 4:29
  • For Blaupunkt, it is: Menu > Konfiguration (the farthest tab to the right) > Bildformat > PointToPoint – Mitja Jan 29 '17 at 19:08
  • For my panasonic TX-42ASW654 it's Menu > Picture > Screen Settings > 16:9 Overscan > Off – user829755 Jun 5 '17 at 5:00
  • That worked on my 32" Samsung too. Thaks, +1 – ztank1013 Jan 13 '18 at 19:23
8

As the above comments are saying, the problem is most likely due to the TV and not the driver.

However, if you have a Sharp Aquos TV, "Dot by Dot" mode might not be available in the menu as Pakman mentioned; I couldn't find an option for enabling "Dot by Dot" mode anywhere.

Instead, I solved the problem by discovering that my remote has a dedicated "Wide Mode" button for this setting, which looks kind of like this: |<>|. Press it to toggle from Stretch to Dot by Dot mode.

  • 1
    Mine had a button called "View Mode" that did the same. – Marcelo Mason Mar 8 '15 at 6:23
  • phew! found it. this sharp aquos has a stupid menu system – jim smith Feb 16 at 14:03
8

Fixing HDMI overscan on a Samsung TV

I connect my laptop to the HDMI input of my Samsung TV. Due to overscan, The TV annoyingly puts part of the image outside the visible screen, even though the resolution is correctly set to 1080p. Here is a solution:

  • Press Source on your remote
  • Move down to your HDMI source and press Tools
  • Select Edit name Scroll down to PC and select that one

Your screen goes blank for a second – and mission accomplished: the overscan is disabled.

  • 1
    Yes I think this is the real answer for Samsung. Screen fit sounds like that would be some sort of scaling rather than direct pixel mapping. – Shiv Aug 4 '17 at 21:29
4

I'd suggest checking your graphics card driver software, I know ATI comes with overscan options. In windows there was a program called power strip that I used to fix this on mine with Windows 7.

  • There is no overscan option in Cataylst for linux and command line arguments for aticonfig does not work. Fixing xorg.conf does not help either. – user71023 Jun 16 '12 at 15:06
  • Ah, but they do work! After activating the FGLRX driver in Ubuntu 12.04, open the Catalyst Control Center (Administrative) and go to Display Manager > Digital Monitor (1) > Adjustments and drag the scaling option slider from 15% underscan to 0% overscan. – Pakman Aug 30 '12 at 4:22
  • Note: this answer is technically for the restricted AMD driver, not the open source radeon driver like the question asked – Pakman Aug 30 '12 at 4:28
  • I used to use powerstrip. it is a very useful tool that lets you adjust timings on practically any card on the market. In other words its really well tailored to fix just this issue. – Octopus Mar 10 '14 at 6:43
1

Both right,

New TVs are set to allow overscan, so the driver will often do that very overscan that is available when set to a desktop resolution.

So, the driver for the video card - might - have an overscan setting to resolve this if lucky, or as Hew found out you might be able to set the TV to display the incoming signal without overscan.

Try the video display driver first, then if no luck, try your TV settings. It is best to correct in the driver setting first, instead of setting a fixed display.

  • I'd argue that it's better to correct the settings on the display if you're using it primarily as a monitor for computers or game consoles. Having overscan enabled means you're doing extra processing to reduce your effective screen resolution, introducing display lag and making the picture less sharp. – Jonathan Baldwin Oct 29 '16 at 20:02
1

I Have struggled with this problem for longer than I care to say! This may help if you have a NVidia graphics card, and Ubuntu 14.04.

  1. Go to the Ubuntu software center, search for NVidia drivers and download "Nvidia X Server Settings".

  2. Once downloaded, click on the Nvidia icon, and select x server display configuration.

  3. Once there, simply slide the underscan slider until the desired size is achieved.

  • I'd suggest formatting this as a bulleted list so more people will see it. It is the correct answer for 14.04 and nVidia. – semitones Feb 25 '15 at 21:18
0

In my case, activating overscan on the monitor (a Philips 244E) didn't fully solve the problem (the monitor's space was not fully covered). I had to deactivate overscan on the monitor and do it using the AMD catalyst control center (gksudo amdcccle).

0

I using ubuntu 13.10 and had the same overscan problem using a 32" dynex led tv. Im using a shuttle computer with 3rd gen intel graphics 2500 connected buy hdmi cable. I went into my advanced video settings on my tv and turned off overscan (problem fixed)

0

As someone before me wrote: This isn't a software problem. Many TV models behaves differently if the HDMI port input label is set to "PC" or something else.

Make sure that your TV knows what's connected to the other end of your HDMI cable

On my 47" LG LCD I can set it at Menu->Option->Input Label

0

ASPECT Button.

Try switching the aspect ratio of your tv by clicking "aspect" button on your controller(tvformat:auto-scan). I connect my dell laptop to a 22" tv and it works.

0

i've just fixed the issue by changing in the property disply modi to 1920x1080 60Hz. it was 59Hz.

this solved my problem, without doing with the registry.

0

I was attempting to solve this problem this afternoon. A Sharp TV would not let me change selection from "stretch" to "dot by dot". It gave me a message:

No input selection available

A solution that served my purposes (not losing part of the screen) was to switch to the lower resolution of 1360 x 768 instead of 1920 x 1080.

Since I just wanted to run emacs on the TV, losing some resolution was not a big deal.

This is kindof a dumb workaround, but since no-one else seems to mention it, I figured this answer would contribute.

protected by Byte Commander Sep 26 '16 at 22:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.